Commit 5b8f1294 authored by Murray Cumming's avatar Murray Cumming

configure.ac: Use C++11 if the compiler supports it.

For instance, use --std=c++11 when using g++.
This will let gtkmm-2.24 build against newer glibmm versions.
Applications will need to use --std=c++11 too if glibmm is a newer
version.
Of course, you should be using gtkmm 3 anyway.
parent 43ad4829
......@@ -31,7 +31,7 @@ AM_MAINTAINER_MODE
AC_ARG_VAR([ACLOCAL_FLAGS], [aclocal flags, e.g. -I <macro dir>])
MM_PREREQ([0.9.5])
MM_PREREQ([0.9.8])
MM_INIT_MODULE([gdkmm-2.4])
MM_INIT_MODULE([gtkmm-2.4])
......@@ -44,6 +44,8 @@ MM_CONFIG_DOCTOOL_DIR([docs])
AC_SUBST([LIBGTKMM_SO_VERSION], [2:0:1])
AC_PROG_CXX
MM_AX_CXX_COMPILE_STDCXX_11([noext],[optional])
AC_DISABLE_STATIC
AC_LIBTOOL_WIN32_DLL
AC_PROG_LIBTOOL
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment