Commit 35554d5b authored by Kjell Ahlstedt's avatar Kjell Ahlstedt

Require C++11

* configure.ac: Use MM_AX_CXX_COMPILE_STDCXX_11 from mm-common to check for
compiler support for C++11 and use it (-std=c++11 for current versions of g++).
Among other reasons, this is because libsigc++ and glibmm now require C++11,
and gmmproc generates C++11 code.
parent bb6e3cc9
......@@ -15,7 +15,11 @@ m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES])
AM_MAINTAINER_MODE
AC_ARG_VAR([ACLOCAL_FLAGS], [aclocal flags, e.g. -I <macro dir>])
MM_PREREQ([0.9.8])
AC_PROG_CXX
MM_AX_CXX_COMPILE_STDCXX_11([noext],[mandatory])
AC_PATH_PROG([PERL], [perl], [perl])
AC_PROG_SED
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment