Commit bd97127e authored by Benjamin Otte's avatar Benjamin Otte

immodule: Fix includes

Make includes not rely on gtkimmodule.h including gtk.h. This will be
important once we remove gtkimmodule from the include files.

That way, we can achieve not pulling deprecated headers automatically.
parent 1c22053b
......@@ -38,6 +38,8 @@
#include "gtkprivate.h"
#include "gtkintl.h"
#include "deprecated/gtkrc.h"
#define SIMPLE_ID "gtk-im-context-simple"
/**
......
......@@ -24,8 +24,10 @@
#include "gtkimmulticontext.h"
#include "gtkimmodule.h"
#include "gtklabel.h"
#include "gtkmain.h"
#include "gtkradiomenuitem.h"
#include "gtkseparatormenuitem.h"
#include "gtkintl.h"
#include "gtkprivate.h"
......
......@@ -39,6 +39,7 @@
#include "gtk/gtkimmodule.h"
#include "gtk/gtkversion.h"
#include "gtk/deprecated/gtkrc.h"
static void
escape_string (GString *contents, const char *str)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment