Commit abc787a5 authored by Matthias Clasen's avatar Matthias Clasen

Move pangoft2 to Requires.private

We have pango in Requires anyway, and this is just so we
can call pangofc api ourselves.
parent c5e4af76
......@@ -1305,8 +1305,9 @@ else
fi
GTK_PACKAGES="atk cairo cairo-gobject gdk-pixbuf-2.0 gio-2.0"
GTK_PRIVATE_PACKAGES=""
if test "x$enable_x11_backend" = xyes; then
GTK_PACKAGES="$GTK_PACKAGES pangoft2"
GTK_PRIVATE_PACKAGES="$GTK_PRIVATE_PACKAGES pangoft2"
fi
GTK_EXTRA_LIBS=
......@@ -1324,6 +1325,7 @@ PANGO_PREFIX="`$PKG_CONFIG --variable=prefix pango`"
CAIRO_PREFIX="`$PKG_CONFIG --variable=prefix cairo`"
AC_SUBST(GTK_PACKAGES)
AC_SUBST(GTK_PRIVATE_PACKAGES)
AC_SUBST(GTK_EXTRA_LIBS)
AC_SUBST(GTK_EXTRA_CFLAGS)
AC_SUBST(GTK_DEP_LIBS)
......
......@@ -11,5 +11,6 @@ Name: GTK+
Description: GTK+ Graphical UI Library
Version: @VERSION@
Requires: gdk-@GTK_API_VERSION@ @GTK_PACKAGES@
Requires.private: @GTK_PRIVATE_PACKAGES@
Libs: -L${libdir} -lgtk-3 @GTK_EXTRA_LIBS@
Cflags: -I${includedir}/gtk-@GTK_API_VERSION@ @GTK_EXTRA_CFLAGS@
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment