Commit 9af9ab16 authored by Owen Taylor's avatar Owen Taylor Committed by Owen Taylor

Fix versioning to avoid changing the soname!

Mon May  6 12:17:14 2002  Owen Taylor  <otaylor@redhat.com>

        * configure.in: Fix versioning to avoid changing the
        soname!

        [ merge from stable ]

        * Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)

        * m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
        compiling "what went wrong" test case. (#79329)

        * m4macros/gtk-2.0.m4: Remove reference to editing
        pkg-config script. (From Jim Gettys)
parent 189a6cc5
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
2002-05-05 Matthias Clasen <maclas@gmx.de>
Mon May 6 12:17:14 2002 Owen Taylor <otaylor@redhat.com>
* configure.in: Fix versioning to avoid changing the
soname!
[ merge from stable ]
* Makefile.am (EXTRA_DIST): Add ChangeLog.pre-2-0 (#78641)
* m4macros/gtk-2.0.m4: save CFLAGS/LIBS properly when
compiling "what went wrong" test case. (#79329)
* m4macros/gtk-2.0.m4: Remove reference to editing
pkg-config script. (From Jim Gettys)
02-05-05 Matthias Clasen <maclas@gmx.de>
* configure.in: Bump version to 2.1.0, binary, interface age 0.
......
......@@ -13,6 +13,7 @@ EXTRA_DIST = \
NEWS.pre-1-0 \
ChangeLog.pre-1-0 \
ChangeLog.pre-1-2 \
ChangeLog.pre-2-0 \
README.cvs-commits \
README.win32 \
config.h.win32 \
......
......@@ -31,7 +31,7 @@ GTK_MAJOR_VERSION=2
GTK_MINOR_VERSION=1
GTK_MICRO_VERSION=0
GTK_INTERFACE_AGE=0
GTK_BINARY_AGE=0
GTK_BINARY_AGE=100
GTK_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$GTK_MICRO_VERSION
dnl This is the X.Y used in -lgtk-FOO-X.Y
GTK_API_VERSION=2.0
......@@ -46,8 +46,14 @@ AC_SUBST(GTK_API_VERSION)
AC_SUBST(GTK_VERSION)
# libtool versioning
LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
LT_CURRENT=`expr $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
#LT_RELEASE=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION
#LT_CURRENT=`expr $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
#LT_REVISION=$GTK_INTERFACE_AGE
#LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
#LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
LT_RELEASE=$GTK_MAJOR_VERSION.0
LT_CURRENT=`expr 100 '*' $GTK_MINOR_VERSION + $GTK_MICRO_VERSION - $GTK_INTERFACE_AGE`
LT_REVISION=$GTK_INTERFACE_AGE
LT_AGE=`expr $GTK_BINARY_AGE - $GTK_INTERFACE_AGE`
LT_CURRENT_MINUS_AGE=`expr $LT_CURRENT - $LT_AGE`
......@@ -58,9 +64,11 @@ AC_SUBST(LT_AGE)
AC_SUBST(LT_CURRENT_MINUS_AGE)
# Define a string for the earliest version that this release has
# binary compatibility with. This is used for module locations.
# forward/backwards binary compatibility with. This is used for module
# locations. (Should this be backwards-compat instead?)
#
GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
#GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.$GTK_MINOR_VERSION.$LT_CURRENT
GTK_BINARY_VERSION=$GTK_MAJOR_VERSION.0.$LT_CURRENT
AC_SUBST(GTK_BINARY_VERSION)
#
......
......@@ -163,6 +163,8 @@ main ()
:
else
echo "*** Could not run GTK+ test program, checking why..."
ac_save_CFLAGS="$CFLAGS"
ac_save_LIBS="$LIBS"
CFLAGS="$CFLAGS $GTK_CFLAGS"
LIBS="$LIBS $GTK_LIBS"
AC_TRY_LINK([
......@@ -179,9 +181,7 @@ main ()
echo "*** If you have an old version installed, it is best to remove it, although"
echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
[ echo "*** The test program failed to compile or link. See the file config.log for the"
echo "*** exact error that occured. This usually means GTK+ was incorrectly installed"
echo "*** or that you have moved GTK+ since it was installed. In the latter case, you"
echo "*** may want to edit the pkg-config script: $PKG_CONFIG" ])
echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
CFLAGS="$ac_save_CFLAGS"
LIBS="$ac_save_LIBS"
fi
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment