Commit 439b9a3b authored by Benjamin Otte's avatar Benjamin Otte

queryimmodules: Actually fix deprecation warnings

The previous patch still caused warnings. Ooops. That's what you get for
not compiling with -Werror.
parent 5ca2f068
......@@ -23,7 +23,6 @@
#include <glib.h>
#include <glib/gprintf.h>
#include <gmodule.h>
#include <errno.h>
#include <string.h>
......@@ -37,13 +36,10 @@
#define SOEXT ("." G_MODULE_SUFFIX)
#endif
#include "gtk/gtkimmodule.h"
#include "gtk/gtkimcontextinfo.h"
#include "gtk/gtkversion.h"
#undef GDK_DEPRECATED
#undef GDK_DEPRECATED_FOR
#define GDK_DEPRECATED
#define GDK_DEPRECATED_FOR(f)
#define GDK_DISABLE_DEPRECATION_WARNINGS
#undef GTK_DISABLE_DEPRECATED
#include "gtk/deprecated/gtkrc.h"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment