Commit 25aa3dda authored by 15:43:54 2002 Dan Mills's avatar 15:43:54 2002 Dan Mills Committed by Dan Mills

replace gtk-doc version check with an all-sh version that works better,

2002-11-21 15:43:54 2002 Dan Mills  <thunder@ximian.com>

	* configure.in: replace gtk-doc version check with an all-sh
	version that works better,
	also up the required gtk-doc version to 0.10 (#99216).
parent d20ce3a1
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
2002-11-21 15:43:54 2002 Dan Mills <thunder@ximian.com>
* configure.in: replace gtk-doc version check with an all-sh
version that works better,
also up the required gtk-doc version to 0.10 (#99216).
2002-11-21 Matthias Clasen <maclas@gmx.de>
* configure.in: Generate docs/reference/*/version.xml.
......
......@@ -1440,19 +1440,27 @@ AC_SUBST(HTML_DIR)
AC_CHECK_PROG(GTKDOC, gtkdoc-mkdb, true, false)
gtk_doc_min_version=0.9
if $GTKDOC ; then
gtk_doc_min_version=0.10
if $GTKDOC ; then
gtk_doc_version=`gtkdoc-mkdb --version`
AC_MSG_CHECKING([gtk-doc version ($gtk_doc_version) >= $gtk_doc_min_version])
if perl <<EOF ; then
exit (("$gtk_doc_version" =~ /^[[0-9]]+\.[[0-9]]+$/) &&
("$gtk_doc_version" >= "$gtk_doc_min_version") ? 0 : 1);
EOF
IFS="${IFS= }"; gtk_save_IFS="$IFS"; IFS="."
set $gtk_doc_version
for min in $gtk_doc_min_version ; do
cur=$1; shift
if test -z $min ; then break; fi
if test -z $cur ; then GTKDOC=false; break; fi
if test $cur -gt $min ; then break ; fi
if test $cur -lt $min ; then GTKDOC=false; break ; fi
done
IFS="$gtk_save_IFS"
if $GTKDOC ; then
AC_MSG_RESULT(yes)
else
else
AC_MSG_RESULT(no)
GTKDOC=false
fi
fi
fi
AC_CHECK_PROG(DB2HTML, db2html, true, false)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment