Commit 08d42ed8 authored by Javier Jardón's avatar Javier Jardón Committed by Tristan Van Berkom

Deprecate widget flag: GTK_WIDGET_PARENT_SENSITIVE

Use gtk_widget_get_sensitive() on the parent widget instead.

https://bugzilla.gnome.org/show_bug.cgi?id=69872
parent edc65ce1
......@@ -267,13 +267,17 @@ typedef enum
#define GTK_WIDGET_SENSITIVE(wid) ((GTK_WIDGET_FLAGS (wid) & GTK_SENSITIVE) != 0)
#endif
#ifndef GTK_DISABLE_DEPRECATED
/**
* GTK_WIDGET_PARENT_SENSITIVE:
* @wid: a #GtkWidget.
*
* Evaluates to %TRUE if the #GTK_PARENT_SENSITIVE flag has be set on the widget.
*
* Deprecated: 2.20: Use gtk_widget_get_sensitive() on the parent widget instead.
*/
#define GTK_WIDGET_PARENT_SENSITIVE(wid) ((GTK_WIDGET_FLAGS (wid) & GTK_PARENT_SENSITIVE) != 0)
#endif
#ifndef GTK_DISABLE_DEPRECATED
/**
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment