• Matthias Clasen's avatar
    Add versioned deprecation macros · e580c79a
    Matthias Clasen authored
    These macros follow the recent changes in GLibs deprecation
    setup. We now annotate deprecated functions with the version
    they were deprecated in, and you can define the macro
    GDK_VERSION_MIN_REQUIRED to cut off deprecation warnings for
    'recent' deprecations.
    
    At the same time, we introduce version annotations for new API
    and allow you to avoid 'recent' API additions by defining
    GDK_VERSION_MAX_ALLOWED.
    e580c79a
configure.ac 55.7 KB