Commit 50187ae8 authored by Niels Nesse's avatar Niels Nesse Committed by Emmanuele Bassi

gdkgl should use shader version 1.50

Using version 1.20 with a forward compatible 3.2 core context is incorrect
since OpenGL 3.2 deprecates shader version 1.20 (See section E.2). The latest
fglrx drivers will not compile these shaders.

https://bugzilla.gnome.org/show_bug.cgi?id=744203
parent ab919dee
......@@ -147,7 +147,7 @@ static void
use_texture_2d_program (GdkGLContextPaintData *paint_data)
{
const char *vertex_shader_code =
"#version 120\n"
"#version 150\n"
"uniform sampler2D map;"
"attribute vec2 position;\n"
"attribute vec2 uv;\n"
......@@ -157,7 +157,7 @@ use_texture_2d_program (GdkGLContextPaintData *paint_data)
" vUv = uv;\n"
"}\n";
const char *fragment_shader_code =
"#version 120\n"
"#version 150\n"
"varying vec2 vUv;\n"
"uniform sampler2D map;\n"
"void main() {\n"
......@@ -178,7 +178,7 @@ static void
use_texture_rect_program (GdkGLContextPaintData *paint_data)
{
const char *vertex_shader_code =
"#version 120\n"
"#version 150\n"
"uniform sampler2DRect map;"
"attribute vec2 position;\n"
"attribute vec2 uv;\n"
......@@ -188,7 +188,7 @@ use_texture_rect_program (GdkGLContextPaintData *paint_data)
" vUv = uv;\n"
"}\n";
const char *fragment_shader_code =
"#version 120\n"
"#version 150\n"
"varying vec2 vUv;\n"
"uniform sampler2DRect map;\n"
"void main() {\n"
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment