1. 02 Apr, 2022 1 commit
  2. 01 Apr, 2022 1 commit
  3. 08 Nov, 2021 1 commit
  4. 15 Sep, 2021 1 commit
  5. 27 Aug, 2021 1 commit
  6. 05 Aug, 2021 1 commit
  7. 04 Jul, 2021 1 commit
    • John Ralls's avatar
      Don't try to build gnutls with Xcode older than 10.0 · a8eba236
      John Ralls authored
      gnutls built with p11-kit support has a weird side effect of breaking
      g-ir-scanner when using an older Xcode. glib-networking requires
      gnutls to be built with p11-kit, so if Xcode is older than 10.0
      don't build gnutls at all. We always build openssl and glib-networking
      with openssl support which should be sufficient.
      a8eba236
  8. 18 Jun, 2021 1 commit
  9. 12 Apr, 2021 4 commits
  10. 27 Dec, 2020 1 commit
  11. 28 Nov, 2020 1 commit
  12. 17 Nov, 2020 1 commit
  13. 09 Nov, 2020 2 commits
  14. 30 Oct, 2020 1 commit
  15. 27 Oct, 2020 1 commit
  16. 28 Sep, 2020 1 commit
  17. 11 Sep, 2020 1 commit
    • John Ralls's avatar
      Remove meta-gtk-osx-freetype, make modules part of core metamodules. · ca43dd0e
      John Ralls authored
      The basic problem is two circular dependencies in the text handling
      modules:
      1. freetype2 depends on harfbuzz and harfbuzz depends on freetype2.
      2. harbuzz depends on gobject-introspection which depends on cairo which
      depends on harfbuzz.
      
      One more little detail: If pango detects freetype it insists on
      fontconfig as well, and fontconfig needs the freetype built with
      harfbuzz. Both of those need to be built before cairo because pango
      wants the cairoft2 and cairofc. In that case pango also demands harfbuzz
      with freetype2 support and with gobject introspection.
      
      librsvg, required for icon rendering, requires freetype2 but doesn't
      need any of the others.
      
      It proved unreasonably complex to have meta-gtk-osx-freetype as an
      optional module so remove it (a stub remains to prevent breaking
      modulesets that use it).
      ca43dd0e
  18. 30 Aug, 2020 2 commits
  19. 20 Aug, 2020 1 commit
  20. 10 May, 2020 1 commit
  21. 14 Apr, 2020 2 commits
  22. 13 Apr, 2020 5 commits
  23. 06 Apr, 2020 1 commit
    • Antoine Martin's avatar
      library updates · d15913b4
      Antoine Martin authored
      readline 8.0
      openssl 1.1.1f
      libtasn1 4.15
      gnutls 3.5.18
      libgcrypt 1.8.5
      libpsl 0.21.0
      Python 2.7.17
      atk 2.34.1
      libepoxy 1.5.4
      d15913b4
  24. 22 Aug, 2019 1 commit
  25. 24 Mar, 2019 1 commit
  26. 25 Oct, 2018 1 commit
    • Alex Samorukov's avatar
      Stable moduleset updates · b12ff65f
      Alex Samorukov authored and Alex Samorukov's avatar Alex Samorukov committed
      gnumake 4.2.1 added to bootstrap to fix webkit parallel build
      gettext-tools, gettext-runtime: upstream patches added
      libxslt: 1.1.32
      gtk-doc: 1.28
      freetype: 2.9.1
      fontconfig: 2.13.0
      gnutls: 3.5.18, glib added as dependency
      libwebp: 1.0.0
      webkit: unbreak parallel builds
      fix broken repository links
      python: 2.7.15
      pygobject: 2.28.7
      python-six: 1.11.0 (added)
      shared-mime-info: 1.9
      GIMP and GIMP-only dependencies removed to move them to separate repository
      gtk+: 2.24.32, new upstream patches
      cairomm: 1.15.5
      cairo: 1.16.0
      
      fixes:
      
      iso-codes: update checkout dir
      b12ff65f
  27. 16 Oct, 2018 1 commit
  28. 28 Jul, 2018 1 commit
  29. 26 May, 2018 1 commit
  30. 29 Jan, 2018 1 commit
    • John Ralls's avatar
      Add a gtk.14 module to modulesets-stable/gtk-osx.modules · 79efbbc7
      John Ralls authored
      We've discovered on Gramps that versions of Gtk+ newer than gtk+-3.14
      are quite unstable, at least in a pygobject environment. This module
      makes it easier to build a stable bundle for similarly impacted applications.
      
      A companion meta-module, meta-gtk-osx-gtk3.14 is included, simply adjust
      your modules list. Do note that if you have relied in the past on certain
      upstream modules to "pull in" meta-gtk-osx-gtk3 that their dependencies
      have been made "soft" in order to build with either so you'll need to
      explicitly add meta-gtk-osx-gtk3 to ensure that everything is completely
      built.
      79efbbc7