README 1.73 KB
Newer Older
1 2
gspell - a spell-checking library for GTK+ applications
=======================================================
Sébastien Wilmet's avatar
Sébastien Wilmet committed
3

4
This is version 1.8.2 of gspell.
5

6
gspell provides a flexible API to add spell-checking to a GTK+ application.
7

8 9
The gspell library is free software and is released under the terms of the GNU
LGPL version 2.1 or later. See the file 'COPYING' for more information.
10

11
The official web site is:
Sébastien Wilmet's avatar
Sébastien Wilmet committed
12

13
    https://wiki.gnome.org/Projects/gspell
Sébastien Wilmet's avatar
Sébastien Wilmet committed
14

15 16 17
About versions
--------------

18 19 20
gspell follows the GNOME release schedule and uses the same versioning scheme:

    https://developer.gnome.org/programming-guidelines/stable/versioning.html.en
21

22
For example the 1.7.x versions are unstable, and the 1.8.x versions are stable.
23

Sébastien Wilmet's avatar
Sébastien Wilmet committed
24 25 26
Dependencies
------------

27
* GLib >= 2.44
Sébastien Wilmet's avatar
Sébastien Wilmet committed
28
* GTK+ >= 3.20
Sébastien Wilmet's avatar
Sébastien Wilmet committed
29
* Enchant >= 2.1.3
30 31
* iso-codes

32 33 34 35 36
Notes for packagers
-------------------

At least on GNU/Linux, it is better to install hunspell. aspell can be
considered deprecated and doesn't work well with gspell. If both hunspell and
37
aspell are installed, Enchant prefers hunspell by default.
38 39 40 41 42 43

See also:

    https://fedoraproject.org/wiki/Releases/FeatureDictionary
    https://wiki.ubuntu.com/ConsolidateSpellingLibs

44 45
Installation
------------
46

47
Simple install procedure from a tarball:
48 49 50 51 52 53 54

  $ ./configure
  $ make
  [ Become root if necessary ]
  $ make install

See the file 'INSTALL' for more detailed information.
55

56 57 58
From the Git repository, the 'configure' script and the 'INSTALL' file are not
yet generated, so you need to run 'autogen.sh' instead, which takes the same
arguments as 'configure'.
59

60 61
To build the latest version of gspell plus its dependencies from Git, Jhbuild
is recommended:
62 63 64

    https://wiki.gnome.org/Projects/Jhbuild

65 66 67 68
How to contribute
-----------------

See the file 'HACKING'.