pocket: Remove Pocket plugin

It requires gnome-online-accounts Pocket support, and that's getting
removed.

See gnome-online-accounts!18
1 job for master in 3 minutes and 26 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
passed #209415
build_stable

00:03:26