Commit 9897147b authored by J.H.M. Dassen (Ray)'s avatar J.H.M. Dassen (Ray)

Updated debianisation

parent c351703f
gnumeric (1.5.2-1) unstable; urgency=low
* New upstream release.
* Fixed upstream:
* sumif behaviour with intersheet references. (Closes: #308346)
* Brown bag text import problem. (Closes: #310832)
* [debian/control] Bumped goffice and libgsf build dependencies
per configure.in.
* [debian/rules, debian/gnumeric.install] Install libspreadsheet runtime
files. Libspreadsheet is not a fully rounded separate library at this
point and the gnumeric binary package contains the only binaries
currently using it, so there is no need yet for it to be in a separate
package. This may well change in the future.
* [debian/rules, debian/gnumeric.install] Build and include ssindex.
(Closes: #311534)
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Tue, 14 Jun 2005 22:38:59 +0200
gnumeric (1.5.1-1) unstable; urgency=low
* New upstream development release.
......@@ -84,88 +102,6 @@ gnumeric (1.4.3-1) unstable; urgency=medium
* [debian/gnumeric.install, debian/gnumeric-doc.install] Cleaned up.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sun, 13 Mar 2005 17:32:09 +0100
=======
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Mon, 16 May 2005 22:06:43 +0200
gnumeric (1.4.3-6) unstable; urgency=high
* [ChangeLog, NEWS, omf.make, src/dependent.c, xmldocs.make] Update from
CVS gnumeric-1-4 branch; fixes include:
* Fix crash for sheet-remove on sheets with local dynamic dependencies.
* [debian/rules, debian/gnumeric-doc.install] Applied patch courtesy of
Philipp Sadleder <philipp@sadleder.de> to restore the documentation files
which were lost in -5 due to an accidental switch to upstream CVS's
xmldocs.make. (Closes: #307883)
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Fri, 6 May 2005 22:44:29 +0200
gnumeric (1.4.3-5) unstable; urgency=medium
* [ChangeLog, Makefile.am, NEWS, configure.in, plugins/fn-stat/ChangeLog,
plugins/fn-stat/functions.c, schemas/Makefile.am, src/application.c,
src/cut-n-paste-code/goffice/gui-utils/go-action-combo-text.c,
src/dialogs/dialog-function-select.c, src/dialogs/dialog-preferences.c,
src/gnumeric-gconf-priv.h, src/gnumeric-gconf.c, src/gnumeric-gconf.h,
src/gui-file.c, src/libgnumeric.c, src/libgnumeric.h, src/plugin.c,
src/print-info.c, src/tools/ChangeLog, src/tools/Makefile.am,
src/tools/auto-correct.c, src/tools/goal-seek.c, src/tools/goal-seek.h,
src/wbc-gtk.c] Update from CVS gnumeric-1-4 branch; fixes include:
* Backport fix for case sensitivity of font combo. [upstream #161382]
* Backport TRIMMEAN fix.
* Backport goal-seek fix.
* [Makefile.am] Commented out references to the tools dir (which is not
needed on non-win32).
* Reauto*ed.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sat, 30 Apr 2005 20:06:59 +0200
gnumeric (1.4.3-4) unstable; urgency=high
* [debian/control] Bumped libgda2-dev and libgnomedb2-dev build dependencies
to get runtime dependencies on libgda2-3 and libgnomedb2-4 rather than
libgda2-1 and libgnomedb2-3.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sun, 10 Apr 2005 10:05:20 +0200
gnumeric (1.4.3-3) unstable; urgency=high
* [NEWS, ChangeLog, plugins/fn-math/ChangeLog,
plugins/fn-math/functions.c, src/colrow.c, src/gnumeric-gconf.c,
src/gnumeric-gconf.h, src/dialogs/ChangeLog,
src/dialogs/dialog-stf-export.c] Updated from CVS gnumeric-1-4 branch to
address
* a crash on page setup
http://bugzilla.gnome.org/show_bug.cgi?id=171503
* problems which broke the sumif and countif functions
http://bugzilla.gnome.org/show_bug.cgi?id=171509
(Closes: #303085)
* three leaks in structured text export which caused crashes on exit.
http://bugzilla.gnome.org/show_bug.cgi?id=128936
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Tue, 5 Apr 2005 07:04:02 +0200
gnumeric (1.4.3-2) unstable; urgency=high
* [NEWS, ChangeLog, plugins/qpro/ChangeLog, plugins/qpro/plugin.xml.in,
po/*.po, src/gui-clipboard.c, src/gui-file.c, src/wbc-gtk.c,
src/workbook-control.c] Fixes from CVS gnumeric-1-4 branch, including
a fix for a crash with a non-UTF-8 filename. (Closes: #299805)
* [debian/rules] Configure --with-python=yes. The interpreter name is
currently not configurable.
* [debian/README.Debian] Minor update.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sun, 20 Mar 2005 12:18:38 +0100
gnumeric (1.4.3-1) unstable; urgency=medium
* New upstream bugfix release, possibly the last of the 1.4 (stable) series.
* [debian/watch] Updated.
* [debian/rules] Cleaned up.
* [debian/gnumeric-common.links] New.
* [debian/gnumeric.install, debian/gnumeric-doc.install] Cleaned up.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sun, 13 Mar 2005 17:32:09 +0100
>>>>>>> 1.55
gnumeric (1.4.2-2) unstable; urgency=high
......
......@@ -4,8 +4,8 @@ Priority: optional
Maintainer: J.H.M. Dassen (Ray) <jdassen@debian.org>
Build-Depends: debhelper (>= 4.2.21), dh-buildinfo, gettext, bison, flex,
scrollkeeper, libxml-parser-perl,
zlib1g-dev, libglib2.0-dev (>= 2.6.0), libgsf-1-dev (>= 1.12.0),
libgoffice-1-dev (>= 0.0.1), libxml2-dev (>= 2.6.10-2),
zlib1g-dev, libglib2.0-dev (>= 2.6.0), libgsf-1-dev (>= 1.12.1),
libgoffice-1-dev (>= 0.0.2), libxml2-dev (>= 2.6.10-2),
libpango1.0-dev (>= 1.8.1),
libgtk2.0-dev (>= 2.6.0), libglade2-dev (>= 1:2.4.0-1),
libgnomeprint2.2-dev (>= 2.8.2), libgnomeprintui2.2-dev (>= 2.8.2),
......@@ -13,7 +13,7 @@ Build-Depends: debhelper (>= 4.2.21), dh-buildinfo, gettext, bison, flex,
libgconf2-dev (>= 2.6.2-1), libbonobo2-dev (>= 2.6.2-4),
libbonoboui2-dev (>= 2.6.1-1),
libgnome2-dev (>= 2.4.0-2), libgnomeui-dev (>= 2.4.0-2),
libgsf-gnome-1-dev (>= 1.12.0),
libgsf-gnome-1-dev (>= 1.12.1),
libgda2-dev (>= 1.0.4-1), libgnomedb2-dev (>= 1.0.4-7),
pxlib-dev (>= 0.4.2-1), libperl-dev,
python2.3-dev, python-gtk2-dev
......
/etc/gconf/schemas/*.schemas
/usr/bin/gnumeric*
/usr/bin/ssconvert*
/usr/bin/ssindex*
/usr/lib/libspreadsheet.so.*
/usr/lib/gnumeric/*/plugins/*/*.glade
/usr/lib/gnumeric/*/plugins/*/*.la
/usr/lib/gnumeric/*/plugins/*/*.so
......
......@@ -69,6 +69,9 @@ features+= --without-gb
# Paradox database files plugin
features+= --with-paradox
# Spreadsheet indexer for beagle
features+= --enable-ssindex
confflags := --prefix=/usr --sysconfdir=/etc \
--localstatedir=/var/lib \
--libexecdir=/usr/bin \
......@@ -261,7 +264,7 @@ binary-arch: build install
dh_buildinfo
dh_fixperms -a
# dh_makeshlibs -a
dh_makeshlibs -a
dh_installdeb -a
# dh_perl -a
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment