Commit 82594a56 authored by Jody Goldberg's avatar Jody Goldberg Committed by Jody Goldberg

bump GAL req. ditto. Ditto.


2001-02-11  Jody Goldberg <jgoldberg@home.com>

	* README : bump GAL req.
	* gnumeric.spec.in : ditto.
	* configure.in : Ditto.
parent f5e0dd37
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* README : bump GAL req.
* gnumeric.spec.in : ditto.
* configure.in : Ditto.
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* src/parser.y : Move the state information into a struct so that we
......
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* README : bump GAL req.
* gnumeric.spec.in : ditto.
* configure.in : Ditto.
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* src/parser.y : Move the state information into a struct so that we
......
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* README : bump GAL req.
* gnumeric.spec.in : ditto.
* configure.in : Ditto.
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* src/parser.y : Move the state information into a struct so that we
......
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* README : bump GAL req.
* gnumeric.spec.in : ditto.
* configure.in : Ditto.
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* src/parser.y : Move the state information into a struct so that we
......
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* README : bump GAL req.
* gnumeric.spec.in : ditto.
* configure.in : Ditto.
2001-02-11 Jody Goldberg <jgoldberg@home.com>
* src/parser.y : Move the state information into a struct so that we
......
......@@ -23,7 +23,7 @@ You need:
gtk+ >= 1.2.7 (gnome-libs 1.3 is not supported)
gnome-libs >= 1.0.57 (gnome-libs 2.0 is not supported)
libglade >= 0.14
gal >= 0.4.99.7
gal >= 0.5
gnome-print >= 0.25 (Be careful, newer version may not compile)
gnome-xml >= 1.8.7 (gnome-xml 2.x not supported yet)
......
......@@ -388,13 +388,13 @@ unset libglade_ok
dnl ******************************
dnl Gnome App Lib checking
dnl ******************************
AC_MSG_CHECKING(for Gnome App libraries (GAL) >= 0.4.99.7 )
AC_MSG_CHECKING(for Gnome App libraries (GAL) >= 0.5 )
gal_ok=no
if gnome-config --libs gal > /dev/null 2>&1; then
verstxt=`gnome-config --modversion gal`
vers=`echo "$verstxt" | sed -e "s/gal-//" -e 's/cvs$//' -e 's/pre$//' | \
awk -F. '{ printf "%d", $1*1000000 + $2*10000 + $3*100 + $4; }'`
if test "$vers" -ge 49907; then
if test "$vers" -ge 50000; then
AC_MSG_RESULT($marker_ok found $verstxt)
gal_ok=yes
else
......
......@@ -20,7 +20,7 @@ Requires: gnome-print >= 0.25
Requires: libglade >= 0.14
Requires: libxml >= 1.8.5
Requires: libole2 >= 0.1.7
Requires: gal >= 0.4.99.7
Requires: gal >= 0.5
%description
GNOME (GNU Network Object Model Environment) is a user-friendly set of
......@@ -121,6 +121,9 @@ fi
%{prefix}/lib/gnumeric/%{version}/plugins/*.la
%changelog
* Sat Feb 10 2001 Jody Goldberg <jgoldberg@home.com>
- Updated version requirements for GAL
* Wed Dec 06 2000 Jody Goldberg <jgoldberg@home.com>
- Updated version requirements for GAL
......
......@@ -561,7 +561,7 @@ void
parse_error_free (ParseError *pe)
{
if (pe->message != NULL) {
g_free (pe->message)
g_free (pe->message);
pe->message = NULL;
}
}
......@@ -1599,12 +1599,14 @@ static gboolean
cb_hash_to_list (gpointer key, gpointer value, gpointer user_data)
{
StyleList **res = user_data;
StyleRegion *sr = value;
*res = g_list_prepend (*res, value);
#ifdef DEBUG_STYLE_LIST
StyleRegion *sr = value;
range_dump (&sr->range, "\n");
#endif
*res = g_list_prepend (*res, value);
return TRUE;
}
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment