Commit 4e01a44a authored by Morten Welinder's avatar Morten Welinder

configure: require glib 2.38 or newer.

parent cc7cd2e1
......@@ -14,7 +14,7 @@ Requirements
------------
You need: Debian package name
glib >= 2.28.0 libglib2.0-dev
glib >= 2.38.0 libglib2.0-dev
gtk+ >= 3.8.8 libgtk3.0-dev
libgsf >= 1.14.24 libgsf-1-dev
libgoffice >= 0.10.9 libgoffice-0-8-dev
......
......@@ -157,10 +157,10 @@ libspreadsheet_reqs="
libxml-2.0 >= 2.4.12
"
gnumeric_reqs="$libspreadsheet_reqs
glib-2.0 >= 2.28.0
gobject-2.0 >= 2.28.0
gmodule-2.0 >= 2.28.0
gthread-2.0 >= 2.28.0
glib-2.0 >= 2.38.0
gobject-2.0 >= 2.38.0
gmodule-2.0 >= 2.38.0
gthread-2.0 >= 2.38.0
pango >= 1.24.0
pangocairo >= 1.24.0
"
......
......@@ -16,7 +16,7 @@ BuildRoot: %{_tmppath}/%{name}-%{PACKAGE_VERSION}-root
BuildRequires: goffice-devel >= 0.10.9
BuildRequires: libgsf-devel >= 1.14.24
BuildRequires: libxml-2.0-devel >= 2.4.12
BuildRequires: glib-2.0-devel >= 2.28.0
BuildRequires: glib-2.0-devel >= 2.38.0
BuildRequires: pango-devel >= 1.24.0
BuildRequires: scrollkeeper
Requires: scrollkeeper hicolor-icon-theme
......
......@@ -187,13 +187,6 @@ gnm_pre_parse_init (int argc, gchar const **argv)
g_mem_set_vtable (glib_mem_profiler_table);
}
#if !GLIB_CHECK_VERSION(2,32,0)
g_thread_init (NULL);
#endif
#if !GLIB_CHECK_VERSION(2,36,0)
g_type_init ();
#endif
/* On win32 argv contains 'ansi' encoded args. We need to manually
* pull in the real versions and convert them to utf-8 */
argv = go_shell_argv_to_glib_encoding (argc, argv);
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment