Commit 4b42f7d7 authored by Jody Goldberg's avatar Jody Goldberg Committed by Jody Goldberg

Bump gnome-print req to 0.24 Ditto. Ditto.


2000-09-28  Jody Goldberg <jgoldberg@home.com>

	* configure.in : Bump gnome-print req to 0.24
	* README : Ditto.
	* gnumeric.spec.in : Ditto.

	* configure.in : Fix typo with double 'share'
parent ff07a22f
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* configure.in : Bump gnome-print req to 0.24
* README : Ditto.
* gnumeric.spec.in : Ditto.
* configure.in : Fix typo with double 'share'
2000-09-28 Jody Goldberg <jgoldberg@home.com>
* idl/gnumeric-graphs.idl : Resume using studlyCaps.
......
......@@ -19,19 +19,25 @@ Requirements
You need:
libole2 == 0.1.6
NOTE : libole2 is also known as libgnomeole2
gnome-print == 0.23
libglade == 0.14
gnome-libs >= 1.0.57 (gnome-libs 2.0 is not supported)
glib >= 1.2.7 (glib-libs 1.3 is not supported)
gtk+ >= 1.2.7 (gnome-libs 1.3 is not supported)
gnome-libs >= 1.2.5 (gnome-libs 2.0 is not supported)
libglade == 0.14 (DO NOT USE CVS HEAD, 29/Sep/00 it is broken)
gal >= 0.0.1
gnome-print >= 0.24 (Be careful, newer version may not compile)
gnome-xml >= 1.8.7 (gnome-xml 2.x not supported yet)
NOTE : gnome-xml is also known as libxml
gal >= 0.0.1
libole2 == 0.1.6
NOTE : libole2 is also known as libgnomeole2
Optionally:
bonobo == 0.19
bonobo == CVS HEAD as of 29/Sep/00
NOTE : This is an unstable interface. It is not part of the released
GNOME api and is subject to change. Newer released versions of
bonobo will almost certainly NOT compile with this release of
gnumeric.
Notes regarding plugins
-----------------------
......
......@@ -308,14 +308,14 @@ AC_SUBST(GB_LIBS)
dnl ******************************
dnl GnomePrint checking
dnl ******************************
AC_MSG_CHECKING(for GnomePrint libraries >= 0.23)
AC_MSG_CHECKING(for GnomePrint libraries >= 0.24)
if gnome-config --libs print > /dev/null 2>&1; then
vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" -e 's/cvs$//' -e 's/pre$//' | \
awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
if test "$vers" -ge 23; then
if test "$vers" -ge 24; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least GNOME print 0.23 for this version of Gnumeric)
AC_MSG_ERROR(You need at least GNOME print 0.24 for this version of Gnumeric)
fi
else
AC_MSG_ERROR(Did not find GnomePrint installed)
......@@ -440,7 +440,7 @@ dnl ***************************************
dnl IDL flags for non-standard prefixes
if $have_bonobo; then
IDL_FLAGS="-I$datadir/share/idl"
IDL_FLAGS="-I$datadir/idl"
for path in `echo $GNOME_PATH | awk 'BEGIN { RS = ":"; } { print;}'`; do
IDL_FLAGS="$IDL_FLAGS -I$path/share/idl"
done
......
......@@ -16,7 +16,7 @@ Docdir: %{prefix}/doc
Requires: gtk+ >= 1.2.7
Requires: gnome-libs >= 1.0.57
Requires: gnome-print >= 0.23
Requires: gnome-print >= 0.24
Requires: libglade >= 0.14
Requires: libxml >= 1.8.5
Requires: libole2 >= 0.1.4
......@@ -104,6 +104,9 @@ fi
%doc HACKING AUTHORS ChangeLog NEWS BUGS README COPYING TODO
%changelog
* Thu Sept 28 2000 Jody Goldberg <jgoldberg@home.com>
- Updated version requirements for gnome-print
* Wed Sept 20 2000 Jody Goldberg <jgoldberg@home.com>
- Updated version requirements for glade
- Looks like someone already added gal.
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment