Commit 10af7bd9 authored by J.H.M. Dassen (Ray)'s avatar J.H.M. Dassen (Ray)

Updated debianisation

parent 8c7bd55b
gnumeric (1.12.1-1) unstable; urgency=low
* New upstream release, first of the new stable series.
* [debian/control]
* Bumped goffice build dependency as per configure.ac .
* [debian/patches/no-nested-externs-error] Added. Don't build
-Werror=nested-externs as this breaks a test used for GLIB_WITH_NLS
which in turn makes the locales directory come out wrong.
* [debian/gnumeric.install] Include ssdiff.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sat, 09 Mar 2013 22:18:14 +0100
gnumeric (1.12.0-1) unstable; urgency=low
* New upstream release, first of the new stable series.
* [debian/rules] Use dh_autotools-dev_updateconfig instead of our own
config.{guess,sub} handling.
* [debian/control]
* Update build dependencies following gsf and goffice gir
packaging fixes.
* Drop obsoleted python-gtk2-dev build dependency.
* Add autotools-dev build dependency for dh_autotools-dev_updateconfig.
* [debian/patches] None needed currently.
* [debian/watch] Upstream has switched to .xz tarballs.
* Issues fixed in this release or in the 1.11 development series:
* Import of charts in a table:shapes environment in ODF. (Closes: 672451)
* Redefining a deleted name no longer requires a restart. (Closes: 661505)
* Data -> Export Data provides access to all supported export formats.
(Closes: 666699)
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Tue, 01 Jan 2013 18:20:39 +0100
gnumeric (1.11.90-1) experimental; urgency=low
* New upstream development release.
* [debian/patches/update-translations] Post-release translation updates.
* [debian/rules]
* Harden build.
* Enable Introspection support.
* Added --disable-maintainer-mode to configure flags.
* Don't update config.{guess,sub} as part of "clean".
* [debian/control]
* Updated goffice build dependency.
* Updated glib build dependency.
* Updated pango build dependency.
* Updated libgsf build dependency.
* Switched gtk build dependency to gtk3.
* Switched python-gobject build dependency to python-gi-dev.
* Added versioned dpkg-dev build dependency for hardening data.
* Added libgirepository1.0-dev and libgsf and goffice gir build
dependencies for introspection support.
* Updated Standards-Version.
* [debian/gir1.2-gnumeric.dirs, debian/gir1.2-gnumeric.install] New.
* [debian/gnumeric.install, debian/gnumeric-common.install, debian/rules]
Removed references to gconf schemes.
* [debian/gnumeric-common.install] Removed reference to UI files as they
are embedded now.
* [debian/patches/patches/ffd85ed-backport] New. Adding per upstream's
recommendation.
* [debian/patches/re-auto-all] Drop.
* [debian/patches/series] Updated accordingly.
-- J.H.M. Dassen (Ray) <jdassen@debian.org> Sun, 02 Dec 2012 14:52:34 +0100
gnumeric (1.10.17-1) unstable; urgency=low
* New upstream stable release.
......
......@@ -2,20 +2,21 @@ Source: gnumeric
Section: math
Priority: optional
Maintainer: J.H.M. Dassen (Ray) <jdassen@debian.org>
Build-Depends: debhelper (>= 7.0.0), dh-buildinfo,
po-debconf, gettext, bison, flex, rarian-compat | scrollkeeper,
Build-Depends: debhelper (>= 7.0.0), dh-buildinfo, dpkg-dev (>= 1.16.1.1),
autotools-dev, po-debconf, gettext, bison, flex, rarian-compat | scrollkeeper,
intltool (>= 0.29), libxml-parser-perl,
zlib1g-dev, libglib2.0-dev (>= 2.12.0), libgsf-1-dev (>= 1.14.18),
libgoffice-0.8-dev (>= 0.8.15), libxml2-dev (>= 2.6.10-2),
libpango1.0-dev (>= 1.12.0),
libgtk2.0-dev (>= 2.12.0), libart-2.0-dev (>= 2.3.16-5),
zlib1g-dev, libglib2.0-dev (>= 2.28.0), libgsf-1-dev (>= 1.14.24),
libgoffice-0.10-dev (>= 0.10.1), libxml2-dev (>= 2.6.10-2),
libpango1.0-dev (>= 1.24.0),
libgtk-3-dev, libart-2.0-dev (>= 2.3.16-5),
pxlib-dev (>= 0.5.1-2+b1), libperl-dev,
python-dev (>= 2.6.6-3), python-gtk2-dev, python-gobject-dev
python-dev (>= 2.6.6-3), python-gi-dev,
libgirepository1.0-dev
X-Python-Version: >= 2.5
Homepage: http://www.gnumeric.org/
Vcs-git: git://git.gnome.org/gnumeric
Vcs-Browser: http://git.gnome.org/cgit/gnumeric
Standards-Version: 3.9.2
Standards-Version: 3.9.4
Package: gnumeric
Architecture: any
......@@ -108,3 +109,13 @@ Description: spreadsheet application for GNOME - additional plugins
- Python plugin loader;
- additional Python functions;
- GNOME glossary.
Package: gir1.2-gnumeric
Section: introspection
Architecture: any
Depends: ${gir:Depends}, ${misc:Depends}
Description: GObject introspection data for the Gnumeric spreadsheet
This package contains introspection data for the Gnumeric spreadsheet.
.
It can be used by packages using the GIRepository format to generate
dynamic bindings.
usr/lib/girepository-1.0
usr/share/gir-1.0
usr/lib/girepository-*/Gnm-*.typelib
usr/share/gir-*/Gnm-*.gir
/* XPM */
static char *gnome_gnumeric[] = {
/* columns rows colors chars-per-pixel */
"32 32 148 2",
"32 32 148 2 ",
" c #440000",
". c #550000",
"X c #660000",
......
/usr/share/applications/gnumeric.desktop
/usr/share/gnumeric/*.md5sum
/usr/share/gnumeric/*/autoformat-templates/*/*.xml
/usr/share/gnumeric/*/autoformat-templates/*/.category
/usr/share/gnumeric/*/ui/*.ui
# /usr/share/gnumeric/*/ui/*.ui
# /usr/share/gnumeric/*/gnome*/ui/*.xml
# /usr/share/gnumeric/*/idl/*.idl
/usr/share/gnumeric/*/templates/*.gnumeric
......
/etc/gconf/schemas/*.schemas
/usr/bin/gnumeric*
/usr/bin/ssconvert*
/usr/bin/ssdiff*
/usr/bin/ssgrep*
/usr/bin/ssindex*
# /usr/include/libspreadsheet-*/spreadsheet
......
diff -ru gnumeric-1.12.1.old/configure.ac gnumeric-1.12.1/configure.ac
--- gnumeric-1.12.1.old/configure.ac 2013-03-02 00:00:37.000000000 +0100
+++ gnumeric-1.12.1/configure.ac 2013-03-09 22:03:58.000000000 +0100
@@ -269,7 +269,7 @@
-Wchar-subscripts -Wwrite-strings \
-Wdeclaration-after-statement -Wnested-externs \
-Wmissing-noreturn \
- -Werror=missing-prototypes -Werror=nested-externs \
+ -Werror=missing-prototypes \
-Werror=implicit-function-declaration \
-Wmissing-declarations -Wno-pointer-sign \
-Werror=format-security -Wbitwise -Wcast-to-as \
diff -ru gnumeric-1.12.1.old/configure gnumeric-1.12.1/configure
--- gnumeric-1.12.1.old/configure 2013-03-02 00:01:20.000000000 +0100
+++ gnumeric-1.12.1/configure 2013-03-09 22:04:35.000000000 +0100
@@ -6756,7 +6756,8 @@
;;
*)
lt_cv_sys_max_cmd_len=`(getconf ARG_MAX) 2> /dev/null`
- if test -n "$lt_cv_sys_max_cmd_len"; then
+ if test -n "$lt_cv_sys_max_cmd_len" && \
+ test undefined != "$lt_cv_sys_max_cmd_len"; then
lt_cv_sys_max_cmd_len=`expr $lt_cv_sys_max_cmd_len \/ 4`
lt_cv_sys_max_cmd_len=`expr $lt_cv_sys_max_cmd_len \* 3`
else
@@ -7157,10 +7158,6 @@
fi
;;
-gnu*)
- lt_cv_deplibs_check_method=pass_all
- ;;
-
haiku*)
lt_cv_deplibs_check_method=pass_all
;;
@@ -7199,7 +7196,7 @@
;;
# This must be glibc/ELF.
-linux* | k*bsd*-gnu | kopensolaris*-gnu)
+linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
lt_cv_deplibs_check_method=pass_all
;;
@@ -8296,7 +8293,14 @@
LD="${LD-ld} -m elf_i386_fbsd"
;;
x86_64-*linux*)
- LD="${LD-ld} -m elf_i386"
+ case `/usr/bin/file conftest.o` in
+ *x86-64*)
+ LD="${LD-ld} -m elf32_x86_64"
+ ;;
+ *)
+ LD="${LD-ld} -m elf_i386"
+ ;;
+ esac
;;
ppc64-*linux*|powerpc64-*linux*)
LD="${LD-ld} -m elf32ppclinux"
@@ -9870,7 +9874,7 @@
lt_prog_compiler_static='-non_shared'
;;
- linux* | k*bsd*-gnu | kopensolaris*-gnu)
+ linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
case $cc_basename in
# old Intel for x86_64 which still supported -KPIC.
ecc*)
@@ -12040,17 +12044,6 @@
esac
;;
-gnu*)
- version_type=linux # correct to gnu/linux during the next big refactor
- need_lib_prefix=no
- need_version=no
- library_names_spec='${libname}${release}${shared_ext}$versuffix ${libname}${release}${shared_ext}${major} ${libname}${shared_ext}'
- soname_spec='${libname}${release}${shared_ext}$major'
- shlibpath_var=LD_LIBRARY_PATH
- shlibpath_overrides_runpath=no
- hardcode_into_libs=yes
- ;;
-
haiku*)
version_type=linux # correct to gnu/linux during the next big refactor
need_lib_prefix=no
@@ -12167,7 +12160,7 @@
;;
# This must be glibc/ELF.
-linux* | k*bsd*-gnu | kopensolaris*-gnu)
+linux* | k*bsd*-gnu | kopensolaris*-gnu | gnu*)
version_type=linux # correct to gnu/linux during the next big refactor
need_lib_prefix=no
need_version=no
@@ -14212,7 +14205,7 @@
-Wchar-subscripts -Wwrite-strings \
-Wdeclaration-after-statement -Wnested-externs \
-Wmissing-noreturn \
- -Werror=missing-prototypes -Werror=nested-externs \
+ -Werror=missing-prototypes \
-Werror=implicit-function-declaration \
-Wmissing-declarations -Wno-pointer-sign \
-Werror=format-security -Wbitwise -Wcast-to-as \
refresh-config-sub-guess-1.10.17-1
no-nested-externs-error
......@@ -12,10 +12,10 @@ msgstr ""
"PO-Revision-Date: 2010-11-30 08:17+0900\n"
"Last-Translator: Nobuhiro Iwamatsu <iwamatsu@debian.org>\n"
"Language-Team: Japanese <debian-japanese@lists.debian.org>\n"
"Language: ja\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Language: ja\n"
#. Type: title
#. Description
......@@ -32,12 +32,18 @@ msgstr "gnumeric を本当にアップグレードしますか?"
#. Type: boolean
#. Description
#: ../gnumeric.templates:3001
msgid "An instance of gnumeric is currently running. If you upgrade now, it may no longer be able to save its data."
msgstr "実行中の gnumeric を検出しました。もし、gnumeric を今すぐ更新すると、そのデータは一切保存できなくなります。"
msgid ""
"An instance of gnumeric is currently running. If you upgrade now, it may no "
"longer be able to save its data."
msgstr ""
"実行中の gnumeric を検出しました。もし、gnumeric を今すぐ更新すると、そのデー"
"タは一切保存できなくなります。"
#. Type: boolean
#. Description
#: ../gnumeric.templates:3001
msgid "You should close the running instances of gnumeric before upgrading this package."
msgstr "このパッケージをアップグレードする前に、実行中の gnumeric を終了すべきです。"
msgid ""
"You should close the running instances of gnumeric before upgrading this "
"package."
msgstr ""
"このパッケージをアップグレードする前に、実行中の gnumeric を終了すべきです。"
......@@ -9,12 +9,12 @@ msgstr ""
"POT-Creation-Date: 2010-07-31 12:15+0200\n"
"PO-Revision-Date: 2011-03-19 18:03-0300\n"
"Last-Translator: Eder L. Marques <eder@edermarques.net>\n"
"Language-Team: Brazilian Portuguese <debian-l10n-portuguese@lists.debian.org>"
"\n"
"Language-Team: Brazilian Portuguese <debian-l10n-portuguese@lists.debian."
"org>\n"
"Language: pt_BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Language: pt_BR\n"
#. Type: title
#. Description
......@@ -31,23 +31,16 @@ msgstr "Realmente atualizar o gnumeric?"
#. Type: boolean
#. Description
#: ../gnumeric.templates:3001
#| msgid ""
#| "It appears there is an instance of gnumeric running currently. If you "
#| "upgrade gnumeric now, that instance may not be able to save its data "
#| "anymore."
msgid ""
"An instance of gnumeric is currently running. If you upgrade now, it may no "
"longer be able to save its data."
msgstr ""
"Uma instância do gnumeric está atualmente em execução. Se você "
"atualizar agora, ela pode não ser mais capaz de salvar seus dados."
"Uma instância do gnumeric está atualmente em execução. Se você atualizar "
"agora, ela pode não ser mais capaz de salvar seus dados."
#. Type: boolean
#. Description
#: ../gnumeric.templates:3001
#| msgid ""
#| "You are strongly recommended to close the running instances of gnumeric "
#| "prior to upgrading this package."
msgid ""
"You should close the running instances of gnumeric before upgrading this "
"package."
......
......@@ -65,6 +65,8 @@ confflags := --prefix=/usr \
--localstatedir=/var/lib \
--libexecdir=/usr/bin \
--enable-compile-warnings=minimum \
--enable-introspection=yes \
--disable-maintainer-mode \
$(features)
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
......@@ -73,7 +75,11 @@ else
confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif
CFLAGS = -Wall -g
export DEB_BUILD_MAINT_OPTIONS = hardening=+all
DPKG_EXPORT_BUILDFLAGS = 1
include /usr/share/dpkg/buildflags.mk
CFLAGS += -Wall -g
ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
CFLAGS += -O0
......@@ -105,7 +111,7 @@ configure-stamp:
dh_testdir
# Prepare for build
dh_autotools-dev_updateconfig
mkdir build
cd build && env srcdir=`pwd`/.. \
../configure $(confflags) "CC=$(CC) $(LDFLAGS)" "CFLAGS=$(CFLAGS)"
......@@ -139,18 +145,6 @@ clean:
rm -rf debian/tmp build
# Update config.{sub,guess} from autotools-dev, if possible.
-for f in config.sub config.guess ; do \
if test -r /usr/share/misc/$$f ; then \
OLDDATE=`./$$f -t | tr -d -` ; \
NEWDATE=`/usr/share/misc/$$f -t | tr -d -` ; \
if [ $$OLDDATE -lt $$NEWDATE ] ; then \
echo "GNU config automated update of $$f (replacing $$OLDDATE with $$NEWDATE)" 1>&2 ; \
cp -f /usr/share/misc/$$f $$f ; \
fi; \
fi; \
done
debconf-updatepo
-find -type f -name 'Makefile.in' | sed -e 's/\.in$$//' | xargs rm -f
......@@ -208,9 +202,6 @@ install: build
# Low-colour icon for use by the menu system
$(INSTALL) -m 644 debian/gnome-gnumeric.xpm `pwd`/debian/tmp/usr/share/pixmaps/
# Checksums of historical versions of conffiles
$(INSTALL) -m 644 debian/gnumeric-dialogs.schemas.md5sum debian/gnumeric-general.schemas.md5sum debian/gnumeric-plugins.schemas.md5sum `pwd`/debian/tmp/usr/share/gnumeric/
dh_install --sourcedir=`pwd`/debian/tmp --fail-missing
# Name the binary just "gnumeric"
......
version=2
http://ftp.gnome.org/pub/gnome/sources/gnumeric/([\d\.]+)/ \
gnumeric-(.*)\.tar\.gz \
gnumeric-(.*)\.tar\.xz \
debian
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment