Commit 04db5968 authored by Jody Goldberg's avatar Jody Goldberg

update

parent 4d7b7642
......@@ -4,9 +4,8 @@ and longer term bugs.
Release Critical
----------------
- Saving xml should not rely on changing the textdomain to disable translation
of TRUE/FALSE in expressions.
- Fix relocation undo to handle Dependents rather than Cell.
- Evaluate (i.e., eliminate) all instances of "foo == TRUE" in the code.
They're too error prone for comfort.
......@@ -18,6 +17,11 @@ Post 0.57 Changes
Long term breakage
------------------
- locale : Saving xml should not rely on changing the textdomain to
disable translation of TRUE/FALSE in expressions.
: Support parsing and displaying locale specific function
names.
- We should put the sensitization/desensitization of the toolbars
on a timer/idle hander so that it will not trigger until a second
or so after the edit starts/ends. This will decrease the irritating
......
Gnumeric -- The GNOME spreadsheet program
Miguel de Icaza <miguel@kernel.org>
Miguel de Icaza <miguel@helixcode.com>
This is the Gnumeric, the GNOME spreadsheet program.
Gnumeric is licensed under the terms of the GNU GPL included in the
file COPYING.
The goal of this spreadsheet is to become as powerful as other
spreadsheets on the market and do this cleanly and smartly. We have to
do this while being as compatible as possible with Excel.
If you are familiar with Excel, you should be ready to use Gnumeric.
We have tried to clone all of the good features and stay as compatible
as possible with Excel in terms of usability.
The project aims to become a viable replacement for standard commercial
spreadsheets. Providing enough of a compatible feature set that Gnumeric
can be used as a drop in replacement.
Gnumeric is still a young program and it is advancing steadily. If
you are interested in contributing to the development of Gnumeric, you
probably will want to read the doc/Design file. I have scribbled my
ideas on how Gnumeric should be developed in the future in the file
doc/Future-Roadmap.
you are interested in contributing to it's development please send us some
email, there are lots of projects available.
Requirements
------------
......@@ -29,17 +21,17 @@ You need:
libole2 == 0.1.6
NOTE : libole2 is also known as libgnomeole2
gnome-print == 0.21
libglade == 0.13
gnome-print == 0.23
libglade == 0.14
gnome-libs >= 1.0.57 (gnome-libs 2.0 is not supported)
glib >= 1.2.7 (glib-libs 1.3 is not supported)
gtk+ >= 1.2.7 (gnome-libs 1.3 is not supported)
gnome-xml == 1.8.7 (gnome-xml 2.x not supported yet)
gnome-xml >= 1.8.7 (gnome-xml 2.x not supported yet)
NOTE : gnome-xml is also known as libxml
gal >= 0.0.1
Optionally:
bonobo == 0.17
bonobo == 0.19
Notes regarding plugins
-----------------------
......
......@@ -126,8 +126,8 @@ if $perl_val; then
perl_val=false
fi
fi
#
# Disable perl for now
dnl Disable perl until we have an active maintainer
AM_CONDITIONAL(WITH_PERL, false)
dnl **************************************************
......@@ -308,14 +308,14 @@ AC_SUBST(GB_LIBS)
dnl ******************************
dnl GnomePrint checking
dnl ******************************
AC_MSG_CHECKING(for GnomePrint libraries >= 0.21pre)
AC_MSG_CHECKING(for GnomePrint libraries >= 0.23)
if gnome-config --libs print > /dev/null 2>&1; then
vers=`gnome-config --modversion print | sed -e "s/gnome-print-//" -e 's/cvs$//' -e 's/pre$//' | \
awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
if test "$vers" -ge 21; then
if test "$vers" -ge 23; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least GNOME print 0.21pre for this version of Gnumeric)
AC_MSG_ERROR(You need at least GNOME print 0.23 for this version of Gnumeric)
fi
else
AC_MSG_ERROR(Did not find GnomePrint installed)
......@@ -324,13 +324,13 @@ fi
dnl ******************************
dnl LibGlade checking
dnl ******************************
AC_MSG_CHECKING(for Glade libraries >= 0.13)
AC_MSG_CHECKING(for Glade libraries >= 0.14)
if gnome-config --libs libglade > /dev/null 2>&1; then
vers=`gnome-config --modversion libglade | awk 'BEGIN { FS = "."; } { print $1 * 1000 + $2;}'`
if test "$vers" -ge 13; then
if test "$vers" -ge 14; then
AC_MSG_RESULT(found)
else
AC_MSG_ERROR(You need at least libglade 0.13 for this version of Gnumeric)
AC_MSG_ERROR(You need at least libglade 0.14 for this version of Gnumeric)
fi
else
AC_MSG_ERROR(Did not find libGlade installed)
......@@ -372,41 +372,41 @@ fi
dnl ****************
dnl Check for pspell
dnl ****************
try_pspell=true
have_pspell=false
pspell_msg=no
PSPELL_LIBS=""
AC_ARG_WITH(pspell,
[--{with,without}-pspell Compile with Pspell support or without it],
if test x$withval = xno; then
try_pspell=false
fi
if test x$withval = xyes; then
try_pspell=true
fi
)
if $try_pspell; then
AC_PATH_PROG(PSPELL_CONFIG,pspell-config,no)
AC_MSG_CHECKING([for pspell])
if test "$PSPELL_CONFIG" = "no"; then
AC_MSG_RESULT(not found)
else
pspell_ver=`$PSPELL_CONFIG version 2>/dev/null`
AC_MSG_RESULT([found ($pspell_ver)])
AC_CHECK_LIB(pspell, new_pspell_config, have_pspell=true)
if test x$have_pspell = xtrue; then
AC_DEFINE(HAVE_PSPELL)
PSPELL_LIBS="-lpspell"
pspell_msg=yes
fi
fi
fi
AC_SUBST(PSPELL_LIBS)
AM_CONDITIONAL(HAVE_PSPELL, $have_pspell)
dnl
dnl try_pspell=true
dnl have_pspell=false
dnl pspell_msg=no
dnl PSPELL_LIBS=""
dnl
dnl AC_ARG_WITH(pspell,
dnl [--{with,without}-pspell Compile with Pspell support or without it],
dnl if test x$withval = xno; then
dnl try_pspell=false
dnl fi
dnl if test x$withval = xyes; then
dnl try_pspell=true
dnl fi
dnl )
dnl
dnl if $try_pspell; then
dnl AC_PATH_PROG(PSPELL_CONFIG,pspell-config,no)
dnl AC_MSG_CHECKING([for pspell])
dnl if test "$PSPELL_CONFIG" = "no"; then
dnl AC_MSG_RESULT(not found)
dnl else
dnl pspell_ver=`$PSPELL_CONFIG version 2>/dev/null`
dnl AC_MSG_RESULT([found ($pspell_ver)])
dnl
dnl AC_CHECK_LIB(pspell, new_pspell_config, have_pspell=true)
dnl if test x$have_pspell = xtrue; then
dnl AC_DEFINE(HAVE_PSPELL)
dnl PSPELL_LIBS="-lpspell"
dnl pspell_msg=yes
dnl fi
dnl fi
dnl fi
dnl AC_SUBST(PSPELL_LIBS)
dnl AM_CONDITIONAL(HAVE_PSPELL, $have_pspell)
dnl ******************************
dnl Check for Applix SHELF
......@@ -507,7 +507,6 @@ Configuration:
GB Support: ${gb_msg}
Bonobo Support: ${bonobo_msg}
Spell Checking: ${pspell_msg}
"
if $have_bonobo; then
echo "
......
......@@ -4,4 +4,5 @@ gnumeric.junk
gnumeric
func-index.sgml
func-list.sgml
gnumeric.html
index.html
DBTOHTML_OUTPUT_DIR*
......@@ -17,7 +17,7 @@ Docdir: %{prefix}/doc
Requires: gtk+ >= 1.2.7
Requires: gnome-libs >= 1.0.57
Requires: gnome-print >= 0.23
Requires: libglade >= 0.13
Requires: libglade >= 0.14
Requires: libxml >= 1.8.5
Requires: libole2 >= 0.1.4
Requires: gal >= 0.0.1
......@@ -104,6 +104,10 @@ fi
%doc HACKING AUTHORS ChangeLog NEWS README COPYING TODO
%changelog
* Wed Sept 20 2000 Jody Goldberg <jgoldberg@home.com>
- Updated version requirements for glade
- Looks like someone already added gal.
* Wed Sep 20 2000 Kenneth Christiansen <kenneth@gnu.org>
- Made it work with the new autoformatter
- Upped gnome-print to 0.22
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment