Commit 849b2678 authored by Rui Matos's avatar Rui Matos

Add missing gi.require_version() calls

pygobject now warns if we don't explicitly require a version before
importing. This adds the missing calls where appropriate.

For the pygobject change see
https://bugzilla.gnome.org/show_bug.cgi?id=727379 .

https://bugzilla.gnome.org/show_bug.cgi?id=757537
parent e536805c
......@@ -18,6 +18,9 @@
import json
import logging
import gi
gi.require_version("Soup", "2.4")
gi.require_version("SoupGNOME", "2.4")
from gi.repository import GObject
from gi.repository import Soup, SoupGNOME
......
......@@ -19,6 +19,8 @@
import logging
import gi
gi.require_version("GnomeDesktop", "3.0")
from gi.repository import Pango, Gtk, GnomeDesktop
from gtweak.gshellwrapper import GnomeShellFactory
from gtweak.tweakmodel import Tweak, TweakGroup
......
......@@ -25,6 +25,8 @@ import glob
import gtweak
from gtweak.gsettings import GSettingsSetting
import gi
gi.require_version("Notify", "0.7")
from gi.repository import GObject
from gi.repository import GLib
from gi.repository import Gio
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment