build: Bump fwupd dependency to 1.2.7

In commit 28dd972a, fwupd_release_get_categories() was called. While
this is an API introced in fwupd 1.2.7. So bump the fwupd dependency
accordingly.
2 jobs for fwupd-dep in 3 minutes and 2 seconds
latest
Status Job ID Name Coverage
  Build
failed #502493
debian-stable-x86_64

00:00:33

passed #502492
fedora-x86_64

00:03:02

 
Name Stage Failure
failed
debian-stable-x86_64 Build
Uploading artifacts...
WARNING: _build/config.h: no matching files
_build/meson-logs: found 2 matching files

WARNING: _build/debian-stable-x86_64-report.xml: no matching files
Uploading artifacts to coordinator... ok
id=502493 responseStatus=201 Created token=yPUQzToq
Uploading artifacts...
WARNING: _build/debian-stable-x86_64-report.xml: no matching files
ERROR: No files to upload
ERROR: Job failed: exit code 1