Commit 3989cad3 authored by Carlos Garnacho's avatar Carlos Garnacho Committed by Florian Müllner

build: Remove Canberra dependency

It is no longer direct, but rather through mutter API.

!327
parent 2a1f915f
......@@ -73,8 +73,6 @@ else
endif
atk_bridge_dep = dependency('atk-bridge-2.0')
canberra_dep = dependency('libcanberra')
canberra_gtk_dep = dependency('libcanberra-gtk3')
ecal_dep = dependency('libecal-1.2', version: ecal_req)
eds_dep = dependency('libedataserver-1.2', version: eds_req)
gcr_dep = dependency('gcr-base-3', version: gcr_req)
......
......@@ -49,7 +49,6 @@ gnome_shell_deps = [
cogl_pango_dep,
startup_dep,
gi_dep,
canberra_dep, canberra_gtk_dep,
polkit_dep,
gcr_dep,
libsystemd_dep
......
......@@ -104,7 +104,6 @@ libacl: f:libacl-devel d:libacl1-dev # gudev
libcurl: f:libcurl-devel # liboauth. See below for Debian
libffi: fs:libffi-devel d:libffi-dev # gobject-introspection
libsystemd-login: fs:systemd-devel # gnome-session gnome-settings-daemon polkit PackageKit
libtool-ltdl: f:libtool-ltdl-devel d:libltdl-dev # libcanberra
libusb: f:libusb1-devel d:libusb-1.0-0-dev # upower
openssl: f:openssl-devel d:libssl-dev # liboauth
pam: f:pam-devel d:libpam-dev # polkit
......@@ -115,7 +114,6 @@ sane: f:sane-backends-devel d:libsane-dev # colord
sqlite: d:libsqlite3-dev f:sqlite-devel # libsoup
udev: f:libudev-devel d:libudev-dev # gudev
uuid: f:libuuid-devel d:uuid-dev # Networkmanager
vorbis: f:libvorbis-devel d:libvorbis-dev # libcanberra
wireless-tools: f:wireless-tools-devel d:libiw-dev s:libiw-devel # NetworkManager
# python libraries used by gnome-shell wrapper script
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment