Commit 30d43499 authored by Syed Kaleem's avatar Syed Kaleem Committed by Debarshi Ray

flatpak: Fix the tracker and tracker-miners builds

Intltool was removed from version 3.34 of the GNOME SDK, but it's
still used by tracker-miners. Therefore it has to be bundled with the
build.

Tracker's master branches are now being used to develop version 3.0,
and it's not ready for use [1]. Hence the build has to be switched to
use the respective 2.3 branches.

Some changes by Debarshi Ray.

[1] https://discourse.gnome.org/t/tracker-has-branched-for-3-0-use-the-2-3-branch-if-you-want-stability/1889

!118
!125
parent 32d816f3
Pipeline #165264 passed with stages
in 10 minutes and 29 seconds
......@@ -256,7 +256,19 @@
"sources": [
{
"type": "git",
"url": "https://gitlab.gnome.org/GNOME/tracker.git"
"url": "https://gitlab.gnome.org/GNOME/tracker.git",
"branch": "tracker-2.3"
}
]
},
{
"name": "intltool",
"cleanup": [ "*" ],
"sources": [
{
"type": "archive",
"url": "https://launchpad.net/intltool/trunk/0.51.0/+download/intltool-0.51.0.tar.gz",
"sha256": "67c74d94196b153b774ab9f89b2fa6c6ba79352407037c8c14d5aeb334e959cd"
}
]
},
......@@ -284,7 +296,8 @@
"sources": [
{
"type": "git",
"url": "https://gitlab.gnome.org/GNOME/tracker-miners.git"
"url": "https://gitlab.gnome.org/GNOME/tracker-miners.git",
"branch": "tracker-miners-2.3"
}
]
},
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment