Commit 9082d7e6 authored by Vincent Untz's avatar Vincent Untz
Browse files

[build, libpanel-applet] Rename the library to libpanel-applet-3

The library has changed and applets need to be ported; and this will
make it possible to have libpanel-applet-2 parallel-installable.
parent 8d3aacc8
......@@ -63,7 +63,7 @@ CLOCK_SOURCES = \
$(SETTIME_SOURCES)
CLOCK_LDADD = \
../../libpanel-applet/libpanel-applet-2.la \
../../libpanel-applet/libpanel-applet-3.la \
$(CLOCK_LIBS) \
$(LIBPANEL_APPLET_LIBS) \
$(POLKIT_LIBS) \
......
......@@ -14,28 +14,28 @@ INCLUDES = \
FISH_SOURCES = fish.c
FISH_LDADD = \
../../libpanel-applet/libpanel-applet-2.la \
../../libpanel-applet/libpanel-applet-3.la \
$(FISH_LIBS) \
$(LIBPANEL_APPLET_LIBS)
if FISH_INPROCESS
APPLET_IN_PROCESS = true
APPLET_LOCATION = $(pkglibdir)/libfish-applet-2.so
fish_applet_2libdir = $(pkglibdir)
fish_applet_2lib_LTLIBRARIES = libfish-applet-2.la
libfish_applet_2_la_SOURCES = $(FISH_SOURCES)
libfish_applet_2_la_LIBADD = $(FISH_LDADD)
libfish_applet_2_la_LDFLAGS = -module -avoid-version
libfish_applet_2_la_CFLAGS =
APPLET_LOCATION = $(pkglibdir)/libfish-applet.so
fish_applet_libdir = $(pkglibdir)
fish_applet_lib_LTLIBRARIES = libfish-applet.la
libfish_applet_la_SOURCES = $(FISH_SOURCES)
libfish_applet_la_LIBADD = $(FISH_LDADD)
libfish_applet_la_LDFLAGS = -module -avoid-version
libfish_applet_la_CFLAGS =
else
APPLET_IN_PROCESS = false
APPLET_LOCATION = $(libexecdir)/fish-applet-2
APPLET_LOCATION = $(libexecdir)/fish-applet
libexec_PROGRAMS = fish-applet-2
fish_applet_2_SOURCES = $(FISH_SOURCES)
fish_applet_2_LDADD = $(FISH_LDADD)
fish_applet_2_CFLAGS =
libexec_PROGRAMS = fish-applet
fish_applet_SOURCES = $(FISH_SOURCES)
fish_applet_LDADD = $(FISH_LDADD)
fish_applet_CFLAGS =
endif
FISH_BITMAPS = \
......
......@@ -29,7 +29,7 @@ NOTIFICATION_AREA_SOURCES = \
na-marshal.h
NOTIFICATION_AREA_LDADD = \
../../libpanel-applet/libpanel-applet-2.la \
../../libpanel-applet/libpanel-applet-3.la \
$(X_LIBS) \
$(NOTIFICATION_AREA_LIBS) \
$(LIBPANEL_APPLET_LIBS)
......
......@@ -31,7 +31,7 @@ WNCKLET_SOURCES = \
$(wnck_applet_OBJECTS): $(BUILT_SOURCES)
WNCKLET_LDADD = \
../../libpanel-applet/libpanel-applet-2.la \
../../libpanel-applet/libpanel-applet-3.la \
$(WNCKLET_LIBS) \
$(LIBPANEL_APPLET_LIBS)
......
......@@ -15,7 +15,7 @@ GNOME_COMMON_INIT
# change to C+1:0:0
# - If the interface is the same as the previous version, change to C:R+1:A
LIB_PANEL_APPLET_LT_VERSION=2:67:2
LIB_PANEL_APPLET_LT_VERSION=0:0:0
AC_SUBST(LIB_PANEL_APPLET_LT_VERSION)
AM_MAINTAINER_MODE
......@@ -329,8 +329,8 @@ gnome-panel/libegg/Makefile
gnome-panel/libpanel-applet-private/Makefile
gnome-panel/libpanel-util/Makefile
gnome-panel/gnome-panel.desktop.in
libpanel-applet/libpanelapplet-2.0.pc
libpanel-applet/libpanelapplet-2.0-uninstalled.pc
libpanel-applet/libpanelapplet-3.0.pc
libpanel-applet/libpanelapplet-3.0-uninstalled.pc
libpanel-applet/Makefile
po/Makefile.in
applets/Makefile
......
......@@ -6,9 +6,9 @@ INCLUDES = \
$(DISABLE_DEPRECATED_CFLAGS) \
$(WARN_CFLAGS)
lib_LTLIBRARIES = libpanel-applet-2.la
lib_LTLIBRARIES = libpanel-applet-3.la
libpanel_applet_2_la_SOURCES = \
libpanel_applet_3_la_SOURCES = \
$(BUILT_SOURCES) \
panel-applet.h \
panel-applet.c \
......@@ -17,15 +17,15 @@ libpanel_applet_2_la_SOURCES = \
panel-applet-gconf.c \
panel-applet-gconf.h
libpanel_applet_2_la_LDFLAGS = \
libpanel_applet_3_la_LDFLAGS = \
-version-info $(LIB_PANEL_APPLET_LT_VERSION) \
-no-undefined
libpanel_applet_2_la_LIBADD = \
libpanel_applet_3_la_LIBADD = \
$(LIBPANEL_APPLET_LIBS) \
$(X_LIBS)
libpanel_appletincludedir = $(includedir)/panel-2.0
libpanel_appletincludedir = $(includedir)/gnome-panel-3.0/libpanel-applet
libpanel_appletinclude_HEADERS = \
panel-applet.h \
......@@ -36,7 +36,7 @@ noinst_PROGRAMS = test-dbus-applet
test_dbus_applet_LDADD = \
$(LIBPANEL_APPLET_LIBS) \
libpanel-applet-2.la
libpanel-applet-3.la
BUILT_SOURCES = \
panel-applet-enums.c \
......@@ -44,13 +44,13 @@ BUILT_SOURCES = \
panel-applet-marshal.c \
panel-applet-marshal.h
$(libpanel_applet_2_la_OBJECTS) $(test_dbus_applet_OBJECTS): $(BUILT_SOURCES)
$(libpanel_applet_3_la_OBJECTS) $(test_dbus_applet_OBJECTS): $(BUILT_SOURCES)
EXTRA_DIST = \
org.gnome.panel.TestApplet.panel-applet.in \
panel-applet-marshal.list \
libpanelapplet-2.0.pc.in \
libpanelapplet-2.0-uninstalled.pc.in
libpanelapplet-3.0.pc.in \
libpanelapplet-3.0-uninstalled.pc.in
panel-applet-marshal.h: panel-applet-marshal.list $(GLIB_GENMARSHAL)
$(AM_V_GEN)$(GLIB_GENMARSHAL) $< --header --prefix=panel_applet_marshal > $@
......@@ -90,7 +90,7 @@ panel-applet-enums.h: @REBUILD@ $(panel_applet_enum_headers)
$(panel_applet_enum_headers) > $@
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libpanelapplet-2.0.pc
pkgconfig_DATA = libpanelapplet-3.0.pc
CLEANFILES = $(BUILT_SOURCES) $(noinst_DATA)
......
......@@ -3,9 +3,9 @@ exec_prefix=@exec_prefix@
libdir=@libdir@
includedir=@includedir@
Name: libpanel-applet-2
Description: libpanel-applet-2
Name: libpanel-applet-3
Description: libpanel-applet-3
Requires: glib-2.0 gconf-2.0 gtk+-2.0
Version: @VERSION@
Libs: ${pc_top_builddir}/${pcfiledir}/libpanel-applet-2.la
Libs: ${pc_top_builddir}/${pcfiledir}/libpanel-applet-3.la
Cflags: -I${pc_top_builddir}/${pcfiledir}
......@@ -3,9 +3,9 @@ exec_prefix=@exec_prefix@
libdir=@libdir@
includedir=@includedir@
Name: libpanel-applet-2
Description: libpanel-applet-2
Name: libpanel-applet-3
Description: libpanel-applet-3
Requires: glib-2.0 gconf-2.0 gtk+-2.0
Version: @VERSION@
Libs: -L${libdir} -lpanel-applet-2
Cflags: -I${includedir}/panel-2.0
Libs: -L${libdir} -lpanel-applet-3
Cflags: -I${includedir}/gnome-panel-3.0/libpanel-applet
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment