Commit 29e6860b authored by Matthias Clasen's avatar Matthias Clasen
Browse files

Validate PolicyKit policy files

svn path=/trunk/; revision=10900
parent e8b25d6e
2008-02-26 Matthias Clasen <mclasen@redhat.com>
* configure.in: When compiling with PolicyKit support,
check for polkit-policy-file-validate.
2008-02-26 Olav Vitters <olav@bkor.dhs.org>
* configure.in: post-release bump to 2.21.93.
......
2008-02-26 Matthias Clasen <mclasen@redhat.com>
* Makefile.am (check): Validate PolicyKit policy files.
==================== 2.21.92 ====================
2008-02-20 Matthias Clasen <mclasen@redhat.com>
......
......@@ -234,12 +234,17 @@ dbus_conf_DATA = org.gnome.ClockApplet.Mechanism.conf
@INTLTOOL_POLICY_RULE@
polkit_DATA = $(polkit_in_files:.policy.in=.policy)
check:
$(POLKIT_POLICY_FILE_VALIDATE) $(polkit_DATA)
else
dbus_services_DATA =
dbus_conf_DATA =
polkit_DATA =
endif
EXTRA_DIST = \
GNOME_ClockApplet_Factory.server.in.in \
$(schemas_in_files) \
......
......@@ -147,6 +147,8 @@ else
if test "x$HAVE_POLKIT" = "xyes" ; then
AC_DEFINE(HAVE_POLKIT, 1, [Defined if PolicyKit support is enabled])
PKG_CHECK_MODULES(POLKIT_DBUS, polkit-dbus >= $POLKIT_DBUS_REQUIRED dbus-glib-1 >= $DBUS_GLIB_REQUIRED gobject-2.0)
AC_CHECK_PROG([POLKIT_POLICY_FILE_VALIDATE],
[polkit-policy-file-validate], [polkit-policy-file-validate])
fi
fi
AM_CONDITIONAL(HAVE_POLKIT, test "x$HAVE_POLKIT" = "xyes")
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment