• Vincent Untz's avatar
    build: Modernize build system a bit · 04e752f5
    Vincent Untz authored
    Stop using GNOME_COMMON_INIT as it is deprecated.
    Do not use AM_MAINTAINER_MODE as it is not recommended by automake
    developers.
    Use LT_PREREQ & LT_INIT for libtool checks.
    Require intltool 0.40.6 to avoid various bugs.
    Do not use AC_ISC_POSIX, AC_HEADER_STDC, AM_PROG_CC_C_O as they
    shouldn't be needed on modern systems.
    Remove checks for perl and awk, and the useless --disable-rebuilds
    configure flag.
    04e752f5
Makefile.am 6.54 KB