submodules: Update shared-modules

This fixes an issue with the lua library on the flatpak version:
"Failed to open module: liblua.so.5.4: cannot open shared object file:
No such file or directory"
3 jobs for wip/jfelder/shared-module in 5 minutes and 55 seconds (queued for 2 seconds)