flatpak: Build libical from the 3.0 branch

libical 3.0.8 has started to fail building against the latest
GNOME SDK. Align with how Evolution does it and build straight
from the 3.0 branch.
1 job for wip/mlundblad/flatpak-ical-git-3.0 in 8 minutes and 36 seconds (queued for 6 seconds)
latest
Status Name Job ID Coverage
  Test
failed flatpak #1399412
flatpak

00:08:36

 
Name Stage Failure
failed
flatpak Test
Uploading artifacts for failed job
Uploading artifacts...
WARNING: gnome-maps-git.flatpak: no matching files
WARNING: repo.tar: no matching files
.flatpak-builder/build/gnome-maps/_flatpak_build/meson-logs/meson-log.txt: found 1 matching files and directories

WARNING: .flatpak-builder/build/gnome-maps/_flatpak_build/meson-logs/testlog.txt: no matching files
Uploading artifacts as "archive" to coordinator... ok
id=1399412 responseStatus=201 Created token=p85DBKG6
Cleaning up file based variables
ERROR: Job failed: exit code 1