Commit 907fcbf9 authored by Sébastien Wilmet's avatar Sébastien Wilmet

Release 3.28.0

A bit late, but I prefer to release often (6 months is already a long
time), to follow the "release early, release often" principle.

What was missing for the GNOME 3.28.0 date is to import the settings
from latexila, which is now done.

Another thing missing, but that doesn't depend on me, is a new icon.
parent 5e23c8e2
GNOME LaTeX NEWS
Release 3.28.0, 2018-04-08
--------------------------
* Changes for packagers:
- New dependency: dconf.
- Note that since the 3.27.2 version, the project has been renamed from
latexila to gnome-latex.
* User-visible changes:
- On first launch of GNOME LaTeX, import LaTeXila settings and user
data/config files.
- Change Find and Replace shortcut to Ctrl+H, to be like in gedit (thanks to
Robert Griesel).
- Update/improve the user documentation for the spell-checking.
- Translation updates.
* Under the hood changes:
- Project moved to GNOME GitLab.
- Apply GtkSourceView coding style to *.c files.
- Reduce delta between Vala and C coding styles.
- Improve documentation for contributors.
- Finish to port the Math menu to GAction (thanks to Robert Griesel).
Release 3.27.2, 2018-01-17
--------------------------
* Rename LaTeXila to GNOME LaTeX.
......
GNOME LaTeX
===========
This is the version 3.27.3 of GNOME LaTeX.
This is the version 3.28.0 of GNOME LaTeX.
GNOME LaTeX is a LaTeX editor for the GNOME desktop.
......@@ -21,7 +21,7 @@ Dependencies
* GLib >= 2.56
* GTK+ >= 3.22
* GtkSourceView >= 4.0
* Tepl >= 3.99.1 - https://wiki.gnome.org/Projects/Tepl
* Tepl >= 4.0 - https://wiki.gnome.org/Projects/Tepl
* gspell >= 1.0
* gee-0.8 >= 0.10
* dconf
......
......@@ -5,7 +5,7 @@
AC_PREREQ([2.64])
AC_INIT([GNOME LaTeX],
[3.27.3],
[3.28.0],
[https://gitlab.gnome.org/GNOME/gnome-latex/issues],
[gnome-latex],
[https://wiki.gnome.org/Apps/GNOME-LaTeX])
......@@ -32,7 +32,7 @@ LT_INIT
GLIB_REQUIRED_VERSION="2.56"
GTK_REQUIRED_VERSION="3.22"
GTKSOURCEVIEW_REQUIRED_VERSION="4.0"
TEPL_REQUIRED_VERSION="3.99.1"
TEPL_REQUIRED_VERSION="4.0"
GSPELL_REQUIRED_VERSION="1.0"
VALA_REQUIRED_VERSION="0.34"
GEE_REQUIRED_VERSION="0.10"
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment