Commit 58a8d3fb authored by Sébastien Wilmet's avatar Sébastien Wilmet

build: use GLIB_REQUIRED_VERSION variable for --target-glib vala flag

Since I often forget to update the --target-glib when I change
GLIB_REQUIRED_VERSION. The comment was not sufficiently visible.
parent 8ef06d4a
......@@ -28,7 +28,6 @@ LT_PREREQ([2.2])
LT_INIT
# Required dependencies versions
# Update also the --target-glib option in src/Makefile.am.
GLIB_REQUIRED_VERSION="2.56"
GTK_REQUIRED_VERSION="3.22"
GTKSOURCEVIEW_REQUIRED_VERSION="4.0"
......
......@@ -12,7 +12,7 @@ AM_VALAFLAGS = \
--pkg gspell-1 \
--pkg gee-0.8 \
--pkg posix \
--target-glib=2.50 \
--target-glib=@GLIB_REQUIRED_VERSION@ \
--vapidir liblatexila \
--vapidir $(abs_builddir)/liblatexila \
--pkg latexila
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment