Commit d2536a74 authored by Javier Jardón's avatar Javier Jardón

Update autotools configuration

Do not use deprecated autoconf macros
Use new libtool syntax
Use maintainer mode by default
parent 7dde5bc7
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
SUBDIRS = src data doc help po
EXTRA_DIST = \
......
AC_INIT([GNOME Disk Utility],[3.0.0],[https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-disk-utility],[gnome-disk-utility])
AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
AC_CONFIG_SRCDIR([src])
AC_CONFIG_HEADERS([config.h])
AC_CONFIG_MACRO_DIR([m4])
AC_CONFIG_AUX_DIR([build-aux])
AM_INIT_AUTOMAKE([1.9 foreign dist-bzip2 no-dist-gzip])
AM_MAINTAINER_MODE([enable])
AM_MAINTAINER_MODE
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
# libtool versioning - this applies to all libraries in this package
#
......@@ -18,12 +21,13 @@ AC_SUBST(LT_CURRENT)
AC_SUBST(LT_REVISION)
AC_SUBST(LT_AGE)
# Check for programs
AC_PROG_CC
AC_ISC_POSIX
AC_HEADER_STDC
AC_PROG_LIBTOOL
m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
# Initialize libtool
LT_PREREQ([2.2])
LT_INIT
#### gcc warning flags
......@@ -106,7 +110,6 @@ fi
# GNOME
# *****
GNOME_COMMON_INIT
GNOME_DOC_INIT
GNOME_DEBUG_CHECK
GNOME_COMPILE_WARNINGS([maximum])
......
include $(top_srcdir)/gnome-doc-utils.make
include $(top_srcdir)/build-aux/gnome-doc-utils.make
dist-hook: doc-dist-hook
DOC_MODULE = palimpsest
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment