Commit edf60cdd authored by Bastien Nocera's avatar Bastien Nocera

wacom: Wacom isn't optional on supported platforms

d78bc977 wrongly made the Wacom panel optional on supported platforms.
Restore the original behaviour which is to require the Wacom panel to be
built on all Linux versions (except s390 which doesn't have USB
support).

See https://bugzilla.gnome.org/show_bug.cgi?id=728318
parent 97a78516
......@@ -297,11 +297,9 @@ case $host_os in
xi >= 1.2 x11 libwacom >= $LIBWACOM_REQUIRED_VERSION
gnome-desktop-3.0 >= $GNOME_DESKTOP_REQUIRED_VERSION
clutter-gtk-1.0
clutter-1.0 >= $CLUTTER_REQUIRED_VERSION, [have_wacom=yes], [have_wacom=no])
if test x${have_wacom} = xyes; then
AC_DEFINE(BUILD_WACOM, 1, [Define to 1 to build the Wacom panel])
AC_DEFINE(HAVE_WACOM, 1, [Define to 1 is Wacom is supportted])
fi
clutter-1.0 >= $CLUTTER_REQUIRED_VERSION)
AC_DEFINE(BUILD_WACOM, 1, [Define to 1 to build the Wacom panel])
AC_DEFINE(HAVE_WACOM, 1, [Define to 1 is Wacom is supportted])
fi
;;
*)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment