Commit 8586d99a authored by Marek Kašík's avatar Marek Kašík

printers: Don't show CUPS deprecation warnings

Hide CUPS deprecation warnings by definition of
_PPD_DEPRECATED="".

https://bugzilla.gnome.org/show_bug.cgi?id=696766
parent d1bbe951
......@@ -249,8 +249,16 @@ if test x"$enable_cups" != x"no" ; then
AC_DEFINE(BUILD_PRINTERS, 1, [Define to 1 to build the Printers panel])
# https://bugzilla.gnome.org/show_bug.cgi?id=696766
CUPS_CPPFLAGS=""
if test $CUPS_API_MAJOR -gt 1 -o \
$CUPS_API_MAJOR -eq 1 -a $CUPS_API_MINOR -ge 6 ; then
CUPS_CPPFLAGS=-D_PPD_DEPRECATED=""
fi
CUPS_CFLAGS=`$CUPS_CONFIG --cflags | $SED -e 's/-O\w*//g' -e 's/-m\w*//g'`
CUPS_LIBS=`$CUPS_CONFIG --libs`
AC_SUBST(CUPS_CPPFLAGS)
AC_SUBST(CUPS_CFLAGS)
AC_SUBST(CUPS_LIBS)
fi
......
......@@ -15,6 +15,8 @@ BUILT_SOURCES = \
cc-printers-resources.c \
cc-printers-resources.h
libprinters_la_CPPFLAGS = $(CUPS_CPPFLAGS)
libprinters_la_SOURCES = \
$(BUILT_SOURCES) \
pp-new-printer.c \
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment