subprojects: Update libgvc

This update is necessary to add support for recent UCM related changes
in ALSA and PulseAudio.

See libgnome-volume-control!10
11 jobs for wip/hadess/update-libgvc-3.36 in 4 seconds (queued for 1 second)
latest