Commit 40be2c22 authored by Emmanuele Bassi's avatar Emmanuele Bassi

Move appstream-glib before flatpak

Flatpak depends on it, so we need to build appstream-glib first.
parent 8b83849c
......@@ -920,18 +920,18 @@
"config-opts": ["--enable-compile-warnings=maximum",
"--enable-installed-tests"]},
{"src": "git:https://github.com/ptomato/mozjs.git",
"branch": "mozjs52",
"name": "mozjs52",
"component": "minimal",
"patches": ["mozjs52-buildapi.patch"],
"config-opts": ["--enable-posix-nspr-emulation",
"--disable-jemalloc",
"--disable-tests",
"--disable-strip",
"--with-system-zlib",
"--with-intl-api",
"AUTOCONF=autoconf"]},
{"src": "git:https://github.com/ptomato/mozjs.git",
"branch": "mozjs52",
"name": "mozjs52",
"component": "minimal",
"patches": ["mozjs52-buildapi.patch"],
"config-opts": ["--enable-posix-nspr-emulation",
"--disable-jemalloc",
"--disable-tests",
"--disable-strip",
"--with-system-zlib",
"--with-intl-api",
"AUTOCONF=autoconf"]},
{"src": "gnome-gitlab:GNOME/gjs.git",
"config-opts": ["--enable-installed-tests"]},
......@@ -944,6 +944,19 @@
"--disable-man",
"--enable-installed-tests"]},
{"src": "gnome:gcab",
"patches": ["gcab-no-parallel.patch"],
"config-opts": ["--disable-silent-rules", "--disable-static", "--enable-fast-install"]},
{"src": "git:git://github.com/hughsie/appstream-glib.git",
"config-opts": ["--disable-dep11",
"--disable-stemmer",
"--disable-rpm",
"--disable-man",
"--disable-gtk-doc"]},
{"src": "git:https://github.com/hughsie/appdata-tools.git"},
{"src": "flatpak:flatpak",
"config-opts": ["--disable-documentation",
"--enable-installed-tests"]},
......@@ -1073,19 +1086,6 @@
{"src": "git:git://github.com/hughsie/colord-gtk.git"},
{"src": "gnome:gcab",
"patches": ["gcab-no-parallel.patch"],
"config-opts": ["--disable-silent-rules", "--disable-static", "--enable-fast-install"]},
{"src": "git:git://github.com/hughsie/appstream-glib.git",
"config-opts": ["--disable-dep11",
"--disable-stemmer",
"--disable-rpm",
"--disable-man",
"--disable-gtk-doc"]},
{"src": "git:https://github.com/hughsie/appdata-tools.git"},
{"src": "gnome:cheese"},
{"src": "gnome:gnome-control-center",
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment