Commit 4c8d8ad9 authored by Marc-André Lureau's avatar Marc-André Lureau

gnome-autogen: warn for deprecated variables

Well, many people still use deprecated variables for 10y, maybe
it's time to let them know.

https://bugzilla.gnome.org/show_bug.cgi?id=741891
parent 89f74f52
......@@ -45,6 +45,23 @@ printerr() {
echo "$@" >&2
}
check_deprecated() {
variable=$1
if set | grep "^$variable=" > /dev/null; then
printerr "***Warning*** $1 is deprecated, you may remove it from autogen.sh"
fi
}
check_deprecated REQUIRED_GNOME_DOC_UTILS_VERSION
check_deprecated REQUIRED_DOC_COMMON_VERSION
check_deprecated USE_COMMON_DOC_BUILD
check_deprecated FORBIDDEN_M4MACROS
check_deprecated GNOME2_DIR
check_deprecated GNOME2_PATH
check_deprecated USE_GNOME2_MACROS
check_deprecated PKG_NAME
PKG_NAME=`autoconf --trace "AC_INIT:$1" "$srcdir/configure.ac"`
# Usage:
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment