Commit fa6274a9 authored by Christian Hergert's avatar Christian Hergert

release 3.27.91

parent 5d618220
===============
Version 3.27.91
===============
This release was pretty quiet which means our stablization efforts last
cycle are paying off.
Changes since last release:
• Various build fixes for some flatpak configurations.
• Don't follow through symlinks when building directory lists. This fixes
a spinloop some users saw when opening projects with symlinks.
• Avoid adding trailing \n when the document already includes a traliing \n.
• Builder now respects --own-name when spawning user projects.
• The editor gutter now provides tooltips with diagnostic information.
• Some vim emulation improvements.
Updated Translations:
German, Polish, Turkish, Indonesian, Galician, Friulian, Spanish, Catalan
===============
Version 3.27.90
===============
......
......@@ -82,6 +82,21 @@
<releases>
<release version="3.27.91" date="2018-02-20">
<description>
<p>
This is a bugfix release for bugs found in 3.27.90.
We would love for you to file bugs for any issues you come across to help us get Builder as stable as possible.
</p>
<ul>
<li>A spinloop was fixed for projects containing symlinks.</li>
<li>Various bugfixes for Flatpak-based projects including support for --own-name.</li>
<li>The editor gutter now supports tooltips when hovering over line numbers.</li>
<li>Various Vim emulation improvements.</li>
</ul>
</description>
</release>
<release version="3.27.90" date="2018-02-04">
<description>
<p>
......
......@@ -60,7 +60,7 @@ author = 'Christian Hergert, et al.'
# The short X.Y version.
version = '3.27'
# The full version, including alpha/beta/rc tags.
release = '3.27.90'
release = '3.27.91'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.27.90',
version: '3.27.91',
meson_version: '>= 0.44.0',
default_options: [
'c_std=gnu11',
......@@ -191,13 +191,13 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.90')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.91')
libgio_dep = dependency('gio-2.0', version: '>= 2.55.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
libgtksource_dep = dependency('gtksourceview-3.0', version: '>= 3.24.0')
libjson_glib_dep = dependency('json-glib-1.0', version: '>= 1.2.0')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.27.90')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.27.91')
libm_dep = cc.find_library('m', required: false)
libpangoft2_dep = dependency('pangoft2', version: '>= 1.38.0')
libpeas_dep = dependency('libpeas-1.0', version: '>= 1.22.0')
......
......@@ -15,8 +15,8 @@ sysprof_sources = [
]
gnome_builder_plugins_deps += [
dependency('sysprof-2', version: '>= 3.26.0'),
dependency('sysprof-ui-2', version: '>= 3.26.0'),
dependency('sysprof-2', version: '>= 3.27.91'),
dependency('sysprof-ui-2', version: '>= 3.27.91'),
]
gnome_builder_plugins_sources += files(sysprof_sources)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment