Commit c29bf778 authored by Christian Hergert's avatar Christian Hergert

release 3.27.92

parent 50c28cbc
===============
Version 3.27.92
===============
Changes since last release:
• Licensing improvements to meson-templates
• Improvements for Language Server Protocol compliance
• The device manager has been improved to support selecting a device
externally to the build configuration. UI is not currently exposed
and may be in a future release.
• The build configuration no longer contains a device.
• A number of build pipeline changes were made to support building for
an architecture other than the host.
• The "local device" is now named "My Computer"
• System architecture has been hoisted into the device info which
allows to more easily support remove devices.
• The code index builder tries harder to avoid blocking the main loop.
• A number of components were moved into the build pipeline to more
cleanly abstract device support.
• The mingw plugin was dropped as it no longer fits into our design
abstractions.
Updated Translations:
Serbian, Serbian Latin, Turkish, Polish, German, Czech, Indonesian,
Catalan, Dutch, Galician, Brazilian Portuguese, Spanish, Korean,
Kazakh, Hungarian, Lithuanian
Distributors:
A new deviced plugin was added, but we do not expect distributions to
ship it by default in 3.28. It is disabled by default.
===============
Version 3.27.91
===============
......
......@@ -82,6 +82,18 @@
<releases>
<release version="3.27.92" date="2018-03-04">
<description>
<p>
This is our last beta release before 3.28.
Please file bugs for any issues you come across.
</p>
<ul>
<li>A number of non-visible changes have occurred in our build pipeline.</li>
</ul>
</description>
</release>
<release version="3.27.91" date="2018-02-20">
<description>
<p>
......
......@@ -60,7 +60,7 @@ author = 'Christian Hergert, et al.'
# The short X.Y version.
version = '3.27'
# The full version, including alpha/beta/rc tags.
release = '3.27.91'
release = '3.27.92'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.27.91',
version: '3.27.92',
meson_version: '>= 0.44.0',
default_options: [
'c_std=gnu11',
......@@ -191,7 +191,7 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.91')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.92')
libgio_dep = dependency('gio-2.0', version: '>= 2.55.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment