Commit 9b699221 authored by Christian Hergert's avatar Christian Hergert

release 3.30.2

parent c6024d57
Pipeline #38311 passed with stage
in 25 minutes and 3 seconds
==============
Version 3.30.2
==============
Changes since last release:
• Fixes for tracking GNOME's Night Light setting
• Fix running of Builder's unit tests without installing
• Fix relative paths from .git gitdir
• Fix gdb communication over chatty intermediate PTY
• Allow gtksourceview-3.0 applications to use Builder style-schemes
• Icon fixes and improvements
• More UI components display keyboard shortcuts
• Saving files will now create the necessary directory structure
• Buffers will mark themselves as "modified on disk" when the backing file
is deleted
• Drop SSL/PKI overrides for Flatpak
• Git plugin now updates status when the checkout directory changes
• Vim command-bar has improved results when listing files/directories
• Project creation and cloning wizards now update paths in response to changes
• ".in" filename suffix will be ignored when guessing syntax language
• You can specify what Ninja path to use using $NINJA in build preferences
• RLS is now restarted when Cargo.toml changes
• Fuzzy matching completion results has been improved for some corner-cases
• Gtk-sharp3 template now builds correctly
• Editor is properly focused when re-selecting open buffer from global search
• Various bug fixes to gstyle
• Meson toolchain editing improvements
Updated Translations:
Serbian, Latvian, Brazilian Portuguese, Polish, Italian, Slovenian, Czech,
Indonesian, Turkish, Romanian, German, Hungarian, Lithuanian, Swedish,
French
==============
Version 3.30.1
==============
......
......@@ -82,6 +82,37 @@
<releases>
<release version="3.30.2" date="2018-10-30">
<description>
<p>
Builder 3.30.2 is a bug-fix release.
</p>
<ul>
<li>Fixes for tracking GNOME's Night Light setting</li>
<li>Fix running of Builder's unit tests without installing</li>
<li>Fix relative paths from .git gitdir</li>
<li>Fix gdb communication over chatty intermediate PTY</li>
<li>Allow gtksourceview-3.0 applications to use Builder style-schemes</li>
<li>Icon fixes and improvements</li>
<li>More UI components display keyboard shortcuts</li>
<li>Saving files will now create the necessary directory structure</li>
<li>Buffers will mark themselves as "modified on disk" when the backing file is deleted</li>
<li>Drop SSL/PKI overrides for Flatpak</li>
<li>Git plugin now updates status when the checkout directory changes</li>
<li>Vim command-bar has improved results when listing files/directories</li>
<li>Project creation and cloning wizards now update paths in response to changes</li>
<li>".in" filename suffix will be ignored when guessing syntax language</li>
<li>You can specify what Ninja path to use using $NINJA in build preferences</li>
<li>RLS is now restarted when Cargo.toml changes</li>
<li>Fuzzy matching completion results has been improved for some corner-cases</li>
<li>Gtk-sharp3 template now builds correctly</li>
<li>Editor is properly focused when re-selecting open buffer from global search</li>
<li>Various bug fixes to gstyle</li>
<li>Meson toolchain editing improvements</li>
</ul>
</description>
</release>
<release version="3.30.1" date="2018-09-24">
<description>
<p>
......@@ -95,7 +126,6 @@
<li>Editor session tracking is more robust in discovering missing files.</li>
<li>New C#, C, and Vala project templates.</li>
<li>CMake build system improvements.</li>
<li></li>
</ul>
</description>
</release>
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.30.1',
version: '3.30.2',
meson_version: '>= 0.47.1',
default_options: [ 'c_std=gnu11',
'cpp_std=c++11',
......@@ -247,13 +247,13 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.92')
libgio_dep = dependency('gio-2.0', version: '>= 2.57.2')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.30.2')
libgio_dep = dependency('gio-2.0', version: '>= 2.58.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.24.0')
libgtksource_dep = dependency('gtksourceview-4', version: '>= 4.0.0')
libjson_glib_dep = dependency('json-glib-1.0', version: '>= 1.2.0')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.29.91')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.30.1')
libm_dep = cc.find_library('m', required: false)
libpangoft2_dep = dependency('pangoft2', version: '>= 1.38.0')
libpeas_dep = dependency('libpeas-1.0', version: '>= 1.22.0')
......
......@@ -15,8 +15,8 @@ sysprof_sources = [
]
gnome_builder_plugins_deps += [
dependency('sysprof-2', version: '>= 3.29.3'),
dependency('sysprof-ui-2', version: '>= 3.29.3'),
dependency('sysprof-2', version: '>= 3.30.2'),
dependency('sysprof-ui-2', version: '>= 3.30.2'),
]
gnome_builder_plugins_sources += files(sysprof_sources)
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment