Commit 5df31add authored by Christian Hergert's avatar Christian Hergert

release 3.27.90

parent b690ae5e
===============
Version 3.27.90
===============
Changes since last release:
• Various fixes for FreeBSD and similar
• The "Projects" directory is now translated and created using the translated
name when applicable. If "Projects" already exists, it is used.
• Fixes and correctness improvements in the beautifier plugin.
• Fixes and correctness improvements in the xml plugin.
• A new "Clone Repository" app-menu item has been added.
• The code-indexer has been restructured to avoid threading in the plugin
API. Plugins are still free to use threads in their implementation.
• A new golang language server client has been added with limited support.
• Many leaks across a variety of plugins have been plugged.
• The flatpak plugin tries even harder to avoid building projects immediate
upon project load.
• The autotools plugin now checks for AC_INIT() inside configure.ac to avoid
being fooled by invalid tooling.
• The configuration manager and providers have been restructured to avoid
threading in plugin APIs.
• Writeback of configuration changes has been improved.
• The editor gutter handles text and icon size changes for zoom.
• The language server protocol client has gotten a number of fixes.
• Preferences improvments.
• The terminal now supports grid selection again.
• Fixes for tab v spaces selection in the document properties pane.
• We now support SDK extensions in flatpak and they will be downloaded.
• A new template for Mono/C♯/Gtk♯ has been added.
• We try even harder to supress unwanted build notifications.
• The make plugin now supports a "run" target.
• A new PTY interceptor has been added so that we can extract build warnings
while also using a real PTY for the terminal widget.
• Ctags now inserts snippets for completion, allowing for parameters expansion.
• Clang plugin now uses language spacing settings when expanding snippets.
This allows for supression of spaces before opening parens.
• Language defaults have been restored, and now properly set the fallback
settings we intended.
• We now log subprocess arguments when building.
Updated Translations:
Lithuanian, Hungarian, Occitan, Spanish, Italian, Finnish, Portuguese
==============
Version 3.27.4
==============
......
......@@ -64,7 +64,7 @@
</screenshots>
<url type="homepage">https://wiki.gnome.org/Apps/Builder</url>
<url type="bugtracker">https://bugzilla.gnome.org/enter_bug.cgi?product=gnome-builder</url>
<url type="bugtracker">https://gitlab.gnome.org/GNOME/gnome-builder/issues</url>
<url type="donation">http://www.gnome.org/friends/</url>
<url type="help">https://builder.readthedocs.io</url>
<project_group>GNOME</project_group>
......@@ -82,6 +82,16 @@
<releases>
<release version="3.27.90" date="2018-02-04">
<description>
<p>
This release is our first Alpha for the upcoming GNOME 3.28 release.
We have primarily been focused on stablizing features added during the cycle.
We would love for you to file bugs for any issues you come across to help us get Builder as stable as possible.
</p>
</description>
</release>
<release version="3.27.4" date="2018-01-08">
<description>
<p>
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.27.4',
version: '3.27.90',
meson_version: '>= 0.44.0',
default_options: [
'c_std=gnu11',
......@@ -191,17 +191,17 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.5')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.27.90')
libgio_dep = dependency('gio-2.0', version: '>= 2.55.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
libgtksource_dep = dependency('gtksourceview-3.0', version: '>= 3.24.0')
libjson_glib_dep = dependency('json-glib-1.0', version: '>= 1.2.0')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.27.4')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.27.90')
libm_dep = cc.find_library('m', required: false)
libpangoft2_dep = dependency('pangoft2', version: '>= 1.38.0')
libpeas_dep = dependency('libpeas-1.0', version: '>= 1.22.0')
libtemplate_glib_dep = dependency('template-glib-1.0', version: '>= 3.27.2')
libtemplate_glib_dep = dependency('template-glib-1.0', version: '>= 3.27.90')
libvte_dep = dependency('vte-2.91', version: '>= 0.40.2')
libxml2_dep = dependency('libxml-2.0', version: '>= 2.9.0')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment