Commit 5154e62b authored by Christian Hergert's avatar Christian Hergert

Release 3.29.91

parent 48e93d3c
Pipeline #25206 passed with stage
in 22 minutes and 52 seconds
===============
Version 3.29.91
===============
Changes since last release:
• gdb breakpoint control improvements
• Build system improvements for NixOS and Flatpak
• Many memory safety and leak improvements
• Icon installation has changed slightly. Please let us know if
you have issues on your distribution.
• A hover provider for language server protocol was added, including
for rls.
• The buffer manager now avoids highlighting while loading the underlying
buffers from storage.
• Terminals now use --login when using bash.
• SIGPIPE is disabled on startup.
• A new session manager that can restore your vertical and horizontal splits.
• Applications can now talk to portals by default when using flatpak.
• Improvements to embedded snippets language defaults.
• Avoid re-downloading of artifacts when possible.
Updated Translations:
Swedish, German, Lithuanian, Spanish, Turkish, Catalan, Italian,
Brazilian Portuguese, Polish
==============
Version 3.29.4
==============
......
......@@ -81,6 +81,16 @@
<translation type="gettext">gnome-builder</translation>
<releases>
<release version="3.29.91" date="2018-08-15">
<description>
<p>
A number of critical bug fixes and memory leaks were fixed this release.
Additionally, projects now restore their sessions including horizontal and vertical splits.
</p>
</description>
</release>
<release version="3.29.4" date="2018-07-17">
<description>
<p>
......
......@@ -60,7 +60,7 @@ author = 'Christian Hergert, et al.'
# The short X.Y version.
version = '3.29'
# The full version, including alpha/beta/rc tags.
release = '3.29.4'
release = '3.29.91'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.29.4',
version: '3.29.91',
meson_version: '>= 0.47.1',
default_options: [ 'c_std=gnu11',
'cpp_std=c++11',
......@@ -248,13 +248,13 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.4')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.91')
libgio_dep = dependency('gio-2.0', version: '>= 2.57.2')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
libgtksource_dep = dependency('gtksourceview-4', version: '>= 4.0.0')
libjson_glib_dep = dependency('json-glib-1.0', version: '>= 1.2.0')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.29.3')
libjsonrpc_glib_dep = dependency('jsonrpc-glib-1.0', version: '>= 3.29.91')
libm_dep = cc.find_library('m', required: false)
libpangoft2_dep = dependency('pangoft2', version: '>= 1.38.0')
libpeas_dep = dependency('libpeas-1.0', version: '>= 1.22.0')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment