Commit 1ec163be authored by Christian Hergert's avatar Christian Hergert

release 3.29.4

parent 5488fec4
Pipeline #20061 failed with stage
in 13 seconds
==============
Version 3.29.4
==============
Changes since last release:
• A new "interactive tooltip" based on GtkPopover has been added
to the editor along with plugin support for "hover providers"
which roughly matches the language server protocol
• Builder now depends on GtkSourceView 4.0
• A number of performance issues have been fixed on large projects
• The todo plugin now uses "git grep" when available
• Enable clang support for Objective-C
• Avoid use of "async" keyword for Python 3.7 support
• Use tooltips to display broken/unsatisfied build pipelines
• Add support for a number of bundled mimetype icons and other
icon quality improvements
• Additional license support in templates
• Additional snippets for various languages
• Improvements to character overwrite support in the editor
• Various toolchain improvements
• Various vim emulation improvements
• A successful build/configure will cause diagnostics to be reloaded
in the open source code views
• Simple support for gdb countpoints
• SSH+git clone improvements when private keys are used
Updated Translations:
German, Romanian
==============
Version 3.29.3
==============
......
......@@ -81,6 +81,15 @@
<translation type="gettext">gnome-builder</translation>
<releases>
<release version="3.29.4" date="2018-07-17">
<description>
<p>
This release includes a brand new interactive tooltip for the source code editor.
A number of critical bug fixes are included as well.
</p>
</description>
</release>
<release version="3.29.3" date="2018-06-18">
<description>
<p>
......
......@@ -60,7 +60,7 @@ author = 'Christian Hergert, et al.'
# The short X.Y version.
version = '3.29'
# The full version, including alpha/beta/rc tags.
release = '3.29.3'
release = '3.29.4'
# The language for content autogenerated by Sphinx. Refer to documentation
# for a list of supported languages.
......
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.29.3',
version: '3.29.4',
meson_version: '>= 0.46.0',
default_options: [ 'c_std=gnu11',
'cpp_std=c++11',
......@@ -248,7 +248,7 @@ ld_supports_version_script = cc.links('''
message('Linker supports --version-script: @0@'.format(ld_supports_version_script))
# Commonly used deps
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.3')
libdazzle_dep = dependency('libdazzle-1.0', version: '>= 3.29.4')
libgio_dep = dependency('gio-2.0', version: '>= 2.56.0')
libgiounix_dep = dependency('gio-unix-2.0')
libgtk_dep = dependency('gtk+-3.0', version: '>= 3.22.26')
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment