podman: Add suport for Podman V2

Podman V2 introduced some changes in the JSON format of some of its
commands[0]. Some changes to the format happened already in the past[1].

With this there should not be need to bump the minimal supported version
of Podman to >=v2.0.0.

[0] https://github.com/containers/libpod/pull/5159
[1] https://github.com/containers/libpod/pull/5582
2 jobs for master in 21 minutes and 31 seconds (queued for 1 second)
Status Job ID Name Coverage
  Test
canceled #800480
flatpak
flatpak

00:21:31

 
  Deploy
canceled #800481
nightly