Commit df9b0c93 authored by Diego Escalante Urrelo's avatar Diego Escalante Urrelo 🍄
Browse files

build: Require meson-0.52.0

Because of changes in meson-0.52.0 we had to change how we use link_with
and link_whole in c8b862b4.

To prevent unforseen behaviors when using older versions of meson,
explicitly require 0.52.0.
parent ba6d907f
project('gnome-builder', 'c',
license: 'GPL3+',
version: '3.35.0',
meson_version: '>= 0.50.0',
meson_version: '>= 0.52.0',
default_options: [ 'c_std=gnu11',
'cpp_std=gnu++2a',
'warning_level=2',
......
  • This is breaking CI, please revert to 0.51.x version.

  • It won't work, 0.51 is broken.

  • FTR, this was me being overly cautious about meson versions and working on separate branches (oops, sorry 🤡 ).

    It should be fine to use 0.51, whether by reverting or manually editing meson.build on your checkout (works fine here). That said I recall we were just waiting for the runtime/sdk to update to meson 0.52.1 when it comes out anyway.

Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment