Commit 7b41e92c authored by Murray Cumming's avatar Murray Cumming
Browse files

1.28.1

parent 4cbb57f1
1.29.1 (stable):
* Use libgda-6.0 instead of libgda-5.0, though image fields are currently not
working.
(Murray Cumming)
* Fix the build with the latest gtkmm.
(Murray Cumming)
* Fix several warnings from the Coverity scan.
(Murray Cumming)
* Use the new Gio::Resource API from glibmm instead of the C API.
(Murray Cumming)
1.28.0 (stable):
* Glade UI files:
......
......@@ -15,7 +15,7 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_INIT([Glom],[1.28.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_INIT([Glom],[1.28.1],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_PREREQ(2.63)
AC_CONFIG_SRCDIR([glom/main.cc])
......@@ -157,13 +157,13 @@ AS_IF([test "x$glom_enable_postgresql" = xyes],
# Libraries used by libglom:
REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.32.0 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-6.0 >= 5.99.1 libgda-6.0 >= 5.2.1 libgda-postgres-6.0 libgda-postgres-6.0 libgda-mysql-6.0 libarchive >= 3.0'
REQUIRED_LIBGLOM_LIBS='giomm-2.4 >= 2.43.1 libxml++-2.6 >= 2.23.1 libxslt >= 1.1.10 pygobject-3.0 >= 2.29.0 libgdamm-6.0 >= 5.99.1 libgda-6.0 >= 5.2.1 libgda-postgres-6.0 libgda-postgres-6.0 libgda-mysql-6.0 libarchive >= 3.0'
AS_IF([test "x$glom_host_win32" != xyes],
[REQUIRED_LIBGLOM_LIBS="$REQUIRED_LIBGLOM_LIBS libepc-1.0 >= 0.4.0"])
# Libraries used by Glom:
REQUIRED_GLOM_LIBS="$REQUIRED_LIBGLOM_LIBS gtkmm-3.0 >= 3.14.0 goocanvasmm-2.0 >= 1.90.8 goocanvas-2.0 >= 2.0.1 evince-view-3.0"
REQUIRED_GLOM_LIBS="$REQUIRED_LIBGLOM_LIBS gtkmm-3.0 >= 3.15.2 goocanvasmm-2.0 >= 1.90.8 goocanvas-2.0 >= 2.0.1 evince-view-3.0"
# Do not require iso-codes in client-only mode, or on Windows:
# TODO: Package iso-codes for Windows?
......
......@@ -303,6 +303,8 @@ public:
static bool handle_error_cerr_only();
private:
bool connect_nothrow();
void on_sharedconnection_finished();
/** We call this when we know that the current connection will no longer work,
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment