Commit 53570d84 authored by Murray Cumming's avatar Murray Cumming
Browse files

1.25.1

parent 2a7a840d
1.25.1 (unstable):
* Startup: Do not crash when reporting check problems.
(Murray Cumming) Bug #680411 (Bjørn Lie, Dominique Leuenberger)
* Initial dialog:
* Fix crash with latest libxml.
(Murray Cumming)
* Fix the notebook vertical expansion with latest GTK+.
(Murray Cumming)
* Avoid a crash at shutdown.
(Murray Cumming)
* Add an AppData file for "GNOME Software".
(Murray Cumming)
* Remove the recent files menu items in the File menu,
because GtkRecentAction has been deprecated without replacement.
(Murray Cumming)
* Avoid the glib warning about adding interfaces after class initialization.
(And therefore require a recent glibmm.)
(Murray Cumming)
* Fix the build and tests with python 3.
You'll need to do something like this:
export PYTHON=python3.3
(do this before starting jhbuild, if you are using jhbuild).
configure --with-boost-python=boost_python-mt-py33
(or autogen.sh if building from git.)
You will also need to have built pygobject with Python3 support.
(Murray Cumming)
* Avoid deprecated Gtk::Stock* API.
(Murray Cumming)
1.24.0 (stable):
* Document format: table node: Remove superfluous parent_table
......
......@@ -15,7 +15,7 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_INIT([Glom],[1.24.0],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_INIT([Glom],[1.25.1],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_PREREQ(2.63)
AC_CONFIG_SRCDIR([glom/main.cc])
......@@ -163,7 +163,7 @@ AS_IF([test "x$glom_host_win32" != xyes],
[REQUIRED_LIBGLOM_LIBS="$REQUIRED_LIBGLOM_LIBS libepc-1.0 >= 0.4.0"])
# Libraries used by Glom:
REQUIRED_GLOM_LIBS="$REQUIRED_LIBGLOM_LIBS gtkmm-3.0 >= 3.4.0 goocanvasmm-2.0 >= 1.90.8 goocanvas-2.0 >= 2.0.1 evince-view-3.0"
REQUIRED_GLOM_LIBS="$REQUIRED_LIBGLOM_LIBS gtkmm-3.0 >= 3.4.0 glibmm-2.4 >= 2.37.93 goocanvasmm-2.0 >= 1.90.8 goocanvas-2.0 >= 2.0.1 evince-view-3.0"
# Do not require iso-codes in client-only mode, or on Windows:
# TODO: Package iso-codes for Windows?
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment