Commit 005796ae authored by Murray Cumming's avatar Murray Cumming
Browse files

Make this (Glom 1.21/22) parallel installable with glom 1.20.

* configure.ac: Increase version to 1.21.1.
* docs/pyglom_reference/Makefile.am:
* glom/libglom/init.h:
* glom/python_embed/python_module/py_glom_module.cc: Change mention of
1.20 or 1_20 to 1.22 or 1_20.
parent 8c20cb0f
2011-12-20 Murray Cumming <murrayc@murrayc.com>
Make this (Glom 1.21/22) parallel installable with glom 1.20.
* configure.ac: Increase version to 1.21.1.
* docs/pyglom_reference/Makefile.am:
* glom/libglom/init.h:
* glom/python_embed/python_module/py_glom_module.cc: Change mention of
1.20 or 1_20 to 1.22 or 1_20.
2011-12-19 Murray Cumming <murrayc@murrayc.com>
TranslatableItem: Improve the API slightly.
......
......@@ -15,7 +15,7 @@
## You should have received a copy of the GNU General Public License
## along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_INIT([Glom],[1.20.2],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_INIT([Glom],[1.21.1],[http://bugzilla.gnome.org/enter_bug.cgi?product=Glom],[glom])
AC_PREREQ(2.63)
AC_CONFIG_SRCDIR([glom/main.cc])
......@@ -37,7 +37,7 @@ LT_INIT([disable-static win32-dll])
# Used for the install directories for headers. The same number is used in
# the library name, which must be kept in sync, but variables can't be used
# with that.
AC_SUBST([GLOM_ABI_VERSION], [1.20])
AC_SUBST([GLOM_ABI_VERSION], [1.22])
AC_DEFINE_UNQUOTED([GLOM_ABI_VERSION], ["$GLOM_ABI_VERSION"],
[Define to the Glom ABI version string.])
......@@ -171,7 +171,7 @@ AC_DEFINE_UNQUOTED([ISO_CODES_PREFIX], ["$ISO_CODES_PREFIX"],
# Allow use of mm-common macros for the warnings option and for installing developer documentation.
MM_PREREQ([0.9.5])
MM_INIT_MODULE([libglom-1.20])
MM_INIT_MODULE([libglom-1.22])
# Copy the mm-common .pl scripts into docs/,
# and use them from there,
......
......@@ -6,7 +6,7 @@
# html:
# pydoc -w $(top_builddir)/glom/python_embed/python_module/.libs/
# mkdir html
# mv glom_1_20.html html/index.html
# mv glom_1_22.html html/index.html
book_name = pyglom_$(GLOM_ABI_VERSION_UNDERLINED)
......
......@@ -59,12 +59,12 @@
*
* If your source file is @c program.cc, you can compile it with:
* @code
* g++ program.cc -o program `pkg-config --cflags --libs glom-1.20`
* g++ program.cc -o program `pkg-config --cflags --libs glom-1.22`
* @endcode
*
* Alternatively, if using autoconf, use the following in @c configure.ac:
* @code
* PKG_CHECK_MODULES([DEPS], [glom-1.20])
* PKG_CHECK_MODULES([DEPS], [glom-1.22])
* @endcode
* Then use the generated @c DEPS_CFLAGS and @c DEPS_LIBS variables in the
* project @c Makefile.am files. For example:
......
......@@ -29,7 +29,7 @@
using namespace Glom;
BOOST_PYTHON_MODULE(glom_1_20)
BOOST_PYTHON_MODULE(glom_1_22)
{
boost::python::docstring_options doc_options(
true, // show the docstrings from here
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment