Commit 9aa98db4 authored by Chun-wei Fan's avatar Chun-wei Fan

Visual Studio builds: Use PythonDir instead of PythonPath

This is to avoid confusion with the PYTHONPATH envvar that is commonly
used to determine where additional Python modules can be loaded,
especially in the case of a MSBuild build.  Note that envvar names are
not case sensitive on Windows in general.
parent 75fa8c2a
......@@ -26,7 +26,7 @@ builds.
A Python 2.7.x or 3.x interpreter is also required, in order to generate
the utility scripts, as well as the pkg-config files for the build. Please
see the entry "PythonPath" in glib-version-paths.props to verify that
see the entry "PythonDir" in glib-version-paths.props to verify that
it is correct.
One may wish to build his/her own ZLib-It is recommended that ZLib is
......
......@@ -84,10 +84,10 @@ copy ..\..\gio\gdbus-2.0\codegen\*.py $(CopyDir)\share\glib-$(ApiVersion)\codege
</GlibDoInstall>
<GlibUtilScripts>..\..\gobject\glib-mkenums;..\..\gobject\glib-genmarshal;..\..\gio\gdbus-2.0\codegen\gdbus-codegen</GlibUtilScripts>
<GlibPCFiles>..\gio-windows-2.0.pc;..\gio-2.0.pc;..\gobject-2.0.pc;..\gmodule-no-export-2.0.pc;..\gmodule-export-2.0.pc;..\gmodule-2.0.pc;..\gthread-2.0.pc;..\glib-2.0.pc</GlibPCFiles>
<GenGLibMKEnums>$(PythonPath)\python.exe ..\gen_util_scripts.py --type=glib-mkenums --version=$(GlibVersion)</GenGLibMKEnums>
<GenGLibGenmarshal>$(PythonPath)\python.exe ..\gen_util_scripts.py --type=glib-genmarshal --version=$(GlibVersion)</GenGLibGenmarshal>
<GenGDBusCodegen>$(PythonPath)\python.exe ..\gen_util_scripts.py --type=gdbus-codegen --version=$(GlibVersion)</GenGDBusCodegen>
<GlibGenPC>(if not exist $(CopyDir) mkdir $(CopyDir)) &amp; ($(PythonPath)\python.exe ..\glibpc.py --prefix=$(CopyDir) --version=$(GlibVersion))</GlibGenPC>
<GenGLibMKEnums>$(PythonDir)\python.exe ..\gen_util_scripts.py --type=glib-mkenums --version=$(GlibVersion)</GenGLibMKEnums>
<GenGLibGenmarshal>$(PythonDir)\python.exe ..\gen_util_scripts.py --type=glib-genmarshal --version=$(GlibVersion)</GenGLibGenmarshal>
<GenGDBusCodegen>$(PythonDir)\python.exe ..\gen_util_scripts.py --type=gdbus-codegen --version=$(GlibVersion)</GenGDBusCodegen>
<GlibGenPC>(if not exist $(CopyDir) mkdir $(CopyDir)) &amp; ($(PythonDir)\python.exe ..\glibpc.py --prefix=$(CopyDir) --version=$(GlibVersion))</GlibGenPC>
</PropertyGroup>
<PropertyGroup>
<_PropertySheetDisplayName>glibinstallprops</_PropertySheetDisplayName>
......
......@@ -12,11 +12,11 @@
<GlibSeparateVSDllSuffix>-2-vs$(VSVer)</GlibSeparateVSDllSuffix>
<GlibDllPrefix>$(GlibSeparateVSDllPrefix)</GlibDllPrefix>
<GlibDllSuffix>$(GlibSeparateVSDllSuffix)</GlibDllSuffix>
<PythonPath Condition="'$(VisualStudioVersion)' == '10.0'">c:\python34</PythonPath>
<PythonPath Condition="'$(VisualStudioVersion)' == '11.0'">c:\python34</PythonPath>
<PythonPath Condition="'$(VisualStudioVersion)' == '12.0'">c:\python34</PythonPath>
<PythonPath Condition="'$(VisualStudioVersion)' == '14.0'">c:\python36</PythonPath>
<PythonPath Condition="'$(VisualStudioVersion)' == '15.0'">c:\python36</PythonPath>
<PythonDir Condition="'$(VisualStudioVersion)' == '10.0'">c:\python34</PythonDir>
<PythonDir Condition="'$(VisualStudioVersion)' == '11.0'">c:\python34</PythonDir>
<PythonDir Condition="'$(VisualStudioVersion)' == '12.0'">c:\python34</PythonDir>
<PythonDir Condition="'$(VisualStudioVersion)' == '14.0'">c:\python36</PythonDir>
<PythonDir Condition="'$(VisualStudioVersion)' == '15.0'">c:\python36</PythonDir>
</PropertyGroup>
<PropertyGroup>
<_PropertySheetDisplayName>glibversionpathsprops</_PropertySheetDisplayName>
......@@ -55,8 +55,8 @@
<BuildMacro Include="GlibDllSuffix">
<Value>$(GlibDllSuffix)</Value>
</BuildMacro>
<BuildMacro Include="PythonPath">
<Value>$(PythonPath)</Value>
<BuildMacro Include="PythonDir">
<Value>$(PythonDir)</Value>
</BuildMacro>
</ItemGroup>
</Project>
......@@ -26,7 +26,7 @@ builds.
A Python 2.7.x or 3.x interpreter is also required, in order to generate
the utility scripts, as well as the pkg-config files for the build. Please
see the entry "PythonPath" in glib-version-paths.vsprops to verify that
see the entry "PythonDir" in glib-version-paths.vsprops to verify that
it is correct.
One may wish to build his/her own ZLib-It is recommended that ZLib is
......
......@@ -86,18 +86,18 @@ copy ..\..\gio\gdbus-2.0\codegen\*.py $(CopyDir)\share\glib-$(ApiVersion)\codege
/>
<UserMacro
Name="GenGLibMKEnums"
Value="$(PythonPath)\python.exe ..\gen_util_scripts.py --type=glib-mkenums --version=$(GlibVersion)"
Value="$(PythonDir)\python.exe ..\gen_util_scripts.py --type=glib-mkenums --version=$(GlibVersion)"
/>
<UserMacro
Name="GenGLibGenmarshal"
Value="$(PythonPath)\python.exe ..\gen_util_scripts.py --type=glib-genmarshal --version=$(GlibVersion)"
Value="$(PythonDir)\python.exe ..\gen_util_scripts.py --type=glib-genmarshal --version=$(GlibVersion)"
/>
<UserMacro
Name="GenGDBusCodegen"
Value="$(PythonPath)\python.exe ..\gen_util_scripts.py --type=gdbus-codegen --version=$(GlibVersion)"
Value="$(PythonDir)\python.exe ..\gen_util_scripts.py --type=gdbus-codegen --version=$(GlibVersion)"
/>
<UserMacro
Name="GlibGenPC"
Value="(if not exist $(CopyDir) mkdir $(CopyDir)) &amp; ($(PythonPath)\python.exe ..\glibpc.py --prefix=$(CopyDir) --version=$(GlibVersion))"
Value="(if not exist $(CopyDir) mkdir $(CopyDir)) &amp; ($(PythonDir)\python.exe ..\glibpc.py --prefix=$(CopyDir) --version=$(GlibVersion))"
/>
</VisualStudioPropertySheet>
......@@ -51,7 +51,7 @@
Value="$(GlibSeparateVSDllSuffix)"
/>
<UserMacro
Name="PythonPath"
Name="PythonDir"
Value="c:\python27"
/>
</VisualStudioPropertySheet>
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment