Commit 475f0a9b authored by Xavier Claessens's avatar Xavier Claessens
parent fa80a2d1
......@@ -817,7 +817,7 @@ endif
schemas_subdir = join_paths('glib-2.0', 'schemas')
pkg.generate(libraries : libgio,
pkg.generate(libgio,
libraries_private : [osx_ldflags],
requires : ['glib-2.0', 'gobject-2.0'],
variables : ['datadir=' + join_paths('${prefix}', get_option('datadir')),
......
......@@ -273,7 +273,8 @@ libglib_dep = declare_dependency(
# We sadly need to export configinc here because everyone includes <glib/*.h>
include_directories : [configinc, glibinc])
pkg.generate(libraries : [libglib, libintl],
pkg.generate(libglib,
libraries : [libintl],
libraries_private : [osx_ldflags, win32_ldflags],
subdirs : ['glib-2.0'],
extra_cflags : ['-I${libdir}/glib-2.0/include'] + win32_cflags,
......
......@@ -109,7 +109,8 @@ libgmodule = library('gmodule-2.0',
supported_var = 'gmodule_supported=@0@'.format(g_module_impl != '0')
pkg.generate(libraries : [libgmodule, thread_dep],
pkg.generate(libgmodule,
libraries : [thread_dep],
requires : ['glib-2.0'],
version : glib_version,
variables : [supported_var],
......
......@@ -74,7 +74,7 @@ libgobject = library('gobject-2.0',
link_args : glib_link_flags,
)
pkg.generate(libraries : libgobject,
pkg.generate(libgobject,
requires : ['glib-2.0'],
version : glib_version,
install_dir : glib_pkgconfigreldir,
......
......@@ -23,7 +23,8 @@ libgthread = library('gthread-2.0',
link_args : glib_link_flags,
)
pkg.generate(libraries : [libgthread, thread_dep],
pkg.generate(libgthread,
libraries : [thread_dep],
requires : ['glib-2.0'],
version : glib_version,
install_dir : glib_pkgconfigreldir,
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment