Commit 31694f9c authored by Dan Winship's avatar Dan Winship

Bump version to 2.41.0, add GLIB_VERSION_2_42, etc

parent 8792609e
......@@ -30,8 +30,8 @@ m4_define(glib_configure_ac)
# <mclasen> on the unstable (ie master), interface age = 0
m4_define([glib_major_version], [2])
m4_define([glib_minor_version], [39])
m4_define([glib_micro_version], [92])
m4_define([glib_minor_version], [41])
m4_define([glib_micro_version], [0])
m4_define([glib_interface_age], [0])
m4_define([glib_binary_age],
[m4_eval(100 * glib_minor_version + glib_micro_version)])
......
......@@ -120,6 +120,9 @@ GLIB_VERSION_2_30
GLIB_VERSION_2_32
GLIB_VERSION_2_34
GLIB_VERSION_2_36
GLIB_VERSION_2_38
GLIB_VERSION_2_40
GLIB_VERSION_2_42
GLIB_VERSION_MIN_REQUIRED
GLIB_VERSION_MAX_ALLOWED
GLIB_DISABLE_DEPRECATION_WARNINGS
......
......@@ -115,6 +115,16 @@
*/
#define GLIB_VERSION_2_40 (G_ENCODE_VERSION (2, 40))
/**
* GLIB_VERSION_2_42:
*
* A macro that evaluates to the 2.42 version of GLib, in a format
* that can be used by the C pre-processor.
*
* Since: 2.42
*/
#define GLIB_VERSION_2_42 (G_ENCODE_VERSION (2, 42))
/* evaluates to the current stable version; for development cycles,
* this means the next stable target
*/
......@@ -318,4 +328,18 @@
# define GLIB_AVAILABLE_IN_2_40 _GLIB_EXTERN
#endif
#if GLIB_VERSION_MIN_REQUIRED >= GLIB_VERSION_2_42
# define GLIB_DEPRECATED_IN_2_42 GLIB_DEPRECATED
# define GLIB_DEPRECATED_IN_2_42_FOR(f) GLIB_DEPRECATED_FOR(f)
#else
# define GLIB_DEPRECATED_IN_2_42 _GLIB_EXTERN
# define GLIB_DEPRECATED_IN_2_42_FOR(f) _GLIB_EXTERN
#endif
#if GLIB_VERSION_MAX_ALLOWED < GLIB_VERSION_2_42
# define GLIB_AVAILABLE_IN_2_42 GLIB_UNAVAILABLE(2, 42)
#else
# define GLIB_AVAILABLE_IN_2_42 _GLIB_EXTERN
#endif
#endif /* __G_VERSION_MACROS_H__ */
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment